Debian 802.1x LDAP

Cian Phillips cian at
Wed Aug 17 03:18:35 CEST 2005

On Aug 16, 2005, at 12:51 PM, Kris Benson wrote:

> FreeRadius users mailing list <freeradius- 
> users at> on
> August 15, 2005 at 23:40 -0800 wrote:
>> rlm_eap: Failed to link EAP-Type/tls: cannot open
>> shared object file: No such file or directory
>> I have googled this and found some messages that suggest compiling
>> from source and using the --shared-disabled flag at compile time but
>> I've tried building from source and can't even get LDAP working..
>> each time I un-comment the ldap line from the radiusd.conf file and
>> try to start using radiusd -x I get a segfault.
> Hi Cian,
> Make sure you have done this:
> apt-get install libssl-dev
> apt-get install libldap2
> apt-get install libldap2-dev
> apt-get install libmysqlclient14
> apt-get install libmysqlclient14-dev
> apt-get install slapd
> apt-get install ldap-utils
> apt-get install db4.2-util
> after those packages are all installed, try compiling again.  If that
> doesn't work, let me know and I can help you further -- this is  
> where I
> solved my problem. :-)

Thanks Kris!

Everything appeared to compile, install and run without any errors.

If you have any tips or good links for up to date information on how  
to set freeradius up to talk to a Cisco WAP I could use the help. <grin>

Thanks again.


More information about the Freeradius-Users mailing list