Freeradius 2.0 with Activedirectory Integration Failed

Anders Holm anders.holm at
Mon Nov 10 08:00:37 CET 2008

You have two errors to fix...


>>> /usr/local/etc/raddb/users[1]: Parse error (check) for entry  
>>> Unknown value ntlm_auth for attribute Auth-Type

And this:

>>> Errors reading /usr/local/etc/raddb/users
>>> /usr/local/etc/raddb/modules/files[7]: Instantiation failed for  
>>> module
>>> "files"
>>> /usr/local/etc/raddb/sites-enabled/inner-tunnel[111]: Failed to find
> module
>>> "files".
>>> /usr/local/etc/raddb/sites-enabled/inner-tunnel[34]: Errors parsing
>>> authorize section.
>>> }
>>> }
>>> Errors initializing modules
>>> It seems like it require an external ntlm_auth to execute, rather  
>>> than one
>>> that is embedded in MSCHAP module.
>> Well, yes. You said you were following the instructions in
>> That's one of the steps. Just add ntlm_auth to authenticate in both
>> virtual servers (default and inner-tunnel).

Is this the step you are struggling with?

> The URL that I was following is using freeradius 1.x

A lot of the documentation on the site is for 1.x so when you have  
figured things out, documenting it is a geeat way to return something  
to the project

> Now, I am using freeradius 2.x, and thus I skipped the creation of  
> "exec
> ntlm_auth"
> Furthermore, I do not know how to do so...

If the docs don't give an example, this is your chance to help getting  
it updated.

> I tried to add it to the "exec" file in the module directory, but it  
> didn't
> work.
> The error is still reported to be the same.

Well, yes, as it is still the same problem.

> Should I fall back to freeradius 1.x instead?


More information about the Freeradius-Users mailing list