Make error - Solved

Olavo jsantos5954 at
Sat Nov 29 19:53:47 CET 2008

Hi all,

I am posting this so it can save some  headaches for other people in the

I've been trying to install FR on a 64 bits OS for a while. First I tried RH
5.2 and I got the following errors

 /usr/bin/libtool --mode=link gcc   -o radmin
> > radmin.lo /usr/lib/ /usr/lib64/
> >/usr/src/redhat/BUILD/freeradius-2.1.1/src/lib/libfreeradius-
> > util.lo log.lo conffile.lo -lnsl -lresolv  -lpthread -lreadline
> >-ltermcap  gcc -o .libs/radmin .libs/radmin.o 
> /usr/lib/
> >/usr/lib64/ .libs/util.o .libs/log.o .libs/conffile.o
> >/usr/src/redhat/BUILD/freeradius-2.1.1/src/lib/.libs/libfreer
> >us.s
> >o -lnsl -lresolv -lpthread -lreadline -ltermcap
> > /usr/lib/ could not read symbols: File in
> wrong format
> > collect2: ld returned 1 exit status
> > gmake[4]: *** [radmin] Error 1

Then I move on to CentOs since Greg Woods informed that he is using it
without any grief. 

When I was making it on CentOS I got the exactly same errors above. Then I
tried to install on Fedora 10 and it installed smoothly. After playing with
Fedora for some time I realized that it is too slow compared to CentOS or RH
and I decided to move back to CentOS and find a way to properly install it.

The clue to fix the problem was provided by Greg when he said that the FR
included with CentOS was too old. When I installed the first time I didn't
realized that there is a FR 1.13 version on CentOS so I didn't installed
along with the OS.

This time I selected 1.13 version and it was installed normally. 

Then I downloaded version FR 2.1  and  it installed smoothly. Now I have 

 radiusd -v
radiusd: FreeRADIUS Version 2.1.1, for host x86_64-unknown-linux-gnu, built
on Nov 28 2008 at 23:06:41

I read somewhere in the site that this is not the recommended way to do it
and that 2.1 should be installed in a different location.

If someone could comment about any problems that can arise it will be


Jair Santos


> -----Original Message-----
> From: 
> at lists.freeradiu
> [ at lists.f
>] On Behalf Of Greg Woods
> Sent: Thursday, November 20, 2008 1:01 PM
> To: FreeRadius users mailing list
> Subject: RE: Make error
> On Thu, 2008-11-20 at 12:38 -0800, Olavo wrote:
> > Does anybody know about any Linux distro 64 bits that 
> Freeradius will 
> > work for sure ?
> I am using it on CentOS 5.2 x86_64. The freeradius package 
> that comes with CentOS 5 is old though, I compiled freeradius 
> from source.
> --Greg
> -
> List info/subscribe/unsubscribe? See 

More information about the Freeradius-Users mailing list