Rlm_ldap not found

José Johnny RANDRIAMAMPIONONA vasiana09 at gmail.com
Wed Sep 30 02:30:41 CEST 2009

I found the solution (anyway it worked with mine):
-try to find what version of openldap is in your system(the default one) by
using the basic command.
-try to find what packages provides the "unfounded" shared file. On cenTos u
can do it with yum whatprovides blablafile.
-if the result is already installed u have to reinstall it, on CentOS u can
do that with yum reinstall blablafile.
It worked for me ...
Thx to the team!
Best regards

2009/9/28 Leighton Man <l.j.man at hud.ac.uk>

> Hi all,
> Hope this is an easy one:
> Freeradius 2.1.6 on arch linux installed from a package. All is well until
> I uncomment ldap in the authorise section of sites-enabled/inner-tunnel then
> I get:
> /etc/raddb/modules/ldap[29]: Failed to link to module 'rlm_ldap': file not
> found
> followed by Failed to find module "ldap" ......
> rlm_ldap.so is a symlink to rlm_ldap-2.1.6.so which has the same
> permissions and is in the same directory as the other modules which load OK
> (they are also symlinks in the same directory).
> I've checked for typos until I'm beginning to see them even when they are
> not there!
> Radiusd -X shows no errors or warnings and after the ***Loading Virtual
> Servers**** message continues linking and instantiating modules up to and
> including "files" then the error above.
> Not easy to post the whole output as I haven't got ftp running yet.
> Where should I look next?
> Regards,
> Leighton
> ---
> This transmission is confidential and may be legally privileged. If you
> receive it in error, please notify us immediately by e-mail and remove it
> from your system. If the content of this e-mail does not relate to the
> business of the University of Huddersfield, then we do not endorse it and
> will accept no liability.
> -
> List info/subscribe/unsubscribe? See
> http://www.freeradius.org/list/users.html

Phone: +212663682554, +212533158575
National School of Applied Sciences
ZIP 1818 TANGIER 90000
---------Morocco ---------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20090930/c913c512/attachment.html>

More information about the Freeradius-Users mailing list