error message connection to MySQL. (Error Message :rlm_sql (sql): There are no DB handles to use! skipped 5, tried to connect 0)

bslee (HKBU) bslee at
Wed Apr 28 09:01:21 CEST 2010


   I try to authenticate freeradius 2.1.8 using mysql5.0.26.
Information of my system:
1. OS is SuSE Linux SLES10 SP2.
2. I have installed following RPM for FreeRadius 2.1.8:
 #rpm -qa |grep freeradius

3. installed following MySQL RPM:
 # rpm -qa |grep mysql

I have successfully installed the RPM for freeradius and test for 
authentication using file "users" is successful.
When I tried to authenticate via MySQL, it failed. There is no connection 
record to MySQL in log file of MySQL.
Searching the WWW, I found out there is a RPM named freeradius-mysql* for 
Red Hat FC. There is no such RPM for SuSE in download website of
 Is corresponding RPM required for SLES10SP2? Where to download?  Or, such 
functionality is already included in one of my installed RPM?

Terminal 1 message:
# radtest user1 test1  localhost 1812  RAD7429secret
Sending Access-Request of id 250 to port 1812
        User-Name = "user1"
        User-Password = "test1"
        NAS-IP-Address =
        NAS-Port = 1812
rad_recv: Access-Reject packet from host port 1812, id=250, 

Terminal 2 message:
Listening on authentication address * port 1812
Listening on accounting address * port 1813
Listening on command file /var/run/radiusd/radiusd.sock
Listening on proxy address * port 1814
Ready to process requests.
rad_recv: Access-Request packet from host port 32768, id=250, 
        User-Name = "user1"
        User-Password = "test1"
        NAS-IP-Address =
        NAS-Port = 1812
+- entering group authorize {...}
++[preprocess] returns ok
[auth_log]      expand: 
il-%Y%m%d -> /var/log/radius/radacct/
[auth_log] /var/log/radius/radacct/%{Client-IP-Address}/auth-detail-%Y%m%d 
ands to /var/log/radius/radacct/
[auth_log]      expand: %t -> Wed Apr 28 20:38:07 2010
++[auth_log] returns ok
++[chap] returns noop
++[mschap] returns noop
[suffix] No '@' in User-Name = "user1", looking up realm NULL
[suffix] No such realm "NULL"
++[suffix] returns noop
[eap] No EAP-Message, not doing EAP
++[eap] returns noop
++[unix] returns notfound
[sql]   expand: %{User-Name} -> user1
[sql] sql_set_user escaped user --> 'user1'
rlm_sql (sql): Ignoring unconnected handle 4..
rlm_sql (sql): Ignoring unconnected handle 3..
rlm_sql (sql): Ignoring unconnected handle 2..
rlm_sql (sql): Ignoring unconnected handle 1..
rlm_sql (sql): Ignoring unconnected handle 0..
rlm_sql (sql): There are no DB handles to use! skipped 5, tried to connect 0
++[sql] returns fail
Using Post-Auth-Type Reject
+- entering group REJECT {...}
[attr_filter.access_reject]     expand: %{User-Name} -> user1
 attr_filter: Matched entry DEFAULT at line 11
++[attr_filter.access_reject] returns updated
Delaying reject of request 0 for 1 seconds
Going to the next request
Waking up in 0.9 seconds.
Sending delayed reject for request 0
Sending Access-Reject of id 250 to port 32768
Waking up in 4.9 seconds.
Cleaning up request 0 ID 250 with timestamp +10
Ready to process requests.


__________ Information from ESET Smart Security, version of virus signature database 5066 (20100427) __________

The message was checked by ESET Smart Security.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list