Freeradius says it is listening on port 1812, but isn't

Matt Harlum matt at
Wed Mar 24 10:27:59 CET 2010

On 24/03/2010, at 8:21 PM, Fajar A. Nugraha wrote:

> On Wed, Mar 24, 2010 at 3:51 PM, Matt Harlum <matt at> wrote:
>> Hi,
>> I'm running Freeradius 2.1.6 on MacOSX 10.5.7 on a Dual-G4 867Mhz PowerMac
>> Since march last year I've had 2.1.6 installed however it's been switched off for the last few months.
>> Recently I powered it back on and have run system updates etc and got to the point I am now
>> When I launch FreeRadius it says it is listening on *:1812 for auth however my AP is unable to connect,
> "unable to connect" is the result. Many things can cause it, from
> incorrent radius IP/secret settings on AP to firewalls blocking
> packets.

Checked both which are correct, no firewalls enabled

>> and trying telnet on port 1812 results in "Connection Refused"
> you can't test UDP with telnet. Try the included radtest and radclient

Ahh ok, I'll give those a try

>> I've tried reverting the configuration to default but it hasn't worked. running radiusd -x does not throw any errors
> does it print incoming packets and process it?
> does tcpdump (or whatever packet capture tools you have) shows incoming packets?

It doesn't show anything when connection attempts are made, I'll let you know how I go with netcat and the radtest tools

> -- 
> Fajar
> -
> List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list