Getting NT_STATUS_WRONG_PASSWORD: Wrong Password (0xc000006a) when using ntlm_auth

lint lint at
Wed Dec 7 19:22:20 CET 2011

Angelica Delgado-2 wrote
> Freeradius, it gives NT_STATUS_WRONG_PASSWORD.

I am having a similar issue to this.  I have LDAP authentication working.
However, my wireless controller, Nortel/Avaya 2382, will not work.

Radius ping from the localhost and a server works fine.

Radius log when I ran a ping from a server configured as a client in
[ntlm_auth] 	expand: --username=%{mschap:User-Name} -> --username=user
[ntlm_auth] 	expand: --password=%{User-Password} -> --password=password
Exec-Program output: NT_STATUS_OK: Success (0x0) 
Exec-Program-Wait: plaintext: NT_STATUS_OK: Success (0x0) 

Radius log when I ran a ping from the wireless controller, which is also a
client in the clients.conf:
[ntlm_auth] 	expand: --username=%{mschap:User-Name} -> --username=user
[ntlm_auth] 	expand: --password=%{User-Password} -> --password=
Exec-Program output: NT_STATUS_WRONG_PASSWORD: Wrong Password (0xc000006a) 
Exec-Program-Wait: plaintext: NT_STATUS_WRONG_PASSWORD: Wrong Password

Eventually, it locks the acocunt in active directory:
[ntlm_auth] 	expand: --username=%{mschap:User-Name} -> --username=user
[ntlm_auth] 	expand: --password=%{User-Password} -> --password=
Exec-Program output: NT_STATUS_ACCOUNT_LOCKED_OUT: Account locked out
Exec-Program-Wait: plaintext: NT_STATUS_ACCOUNT_LOCKED_OUT: Account locked
out (0xc0000234)

I am not sure why the wireless controller will not send the password, or why
FreeRADIUS is not seeing the password.

Any help is very appreciated.

View this message in context:
Sent from the FreeRadius - User mailing list archive at

More information about the Freeradius-Users mailing list