Wired 802.1X + FreeRADIUS + LDAP issue

Alan DeKok aland at deployingradius.com
Sat Dec 10 10:54:04 CET 2011

Ryan Garland wrote:
> I get a Warning message from FreeRADIUS indicating that EAP did not
> complete.  The message directs me to a Certificate Compatibility page on
> the FR wiki, but unfortunately that points a lot of fingers at Windows,
> which my laptop is not running.

  Whether it's windows or not, the supplicant is *always* the one who
chooses to stop doing EAP.

> We have also tried creating the certs with the bootstrap program and
> modifying eap.conf accordingly, to no avail.
> For reference, eapol_test also fails in the same manner when running
> locally on the FreeRADIUS box.

  Uh... then all bets are off.  If eapol_test doesn't work, then you
broke the FR configuration.  FR && eapol_test work together.  I do this
pretty much every day.

  Post the output from eapol_test.  It should produce *many* messages
describing exactly what is going wrong, and why.

> I am sure I am missing something - probably something simple - but I
> just have not been able to figure it out, and I am clearly not very good
> at reading the debug output. :-(

  You read it fine.  Something *else* is going on.

> I have been researching this for quite some time and have found a lot of
> helpful information from people on this list, so I hope somebody can
> help me pinpoint the issue.
> My apologies if I was too wordy.  Any help is greatly appreciated.

  Wordy is better than "I tried stuff and it didn't work."

  Alan DeKok.

More information about the Freeradius-Users mailing list