Fw: Radius Problem EAP/TTLS Openssl support issue

Amrita Mandpe amritamandpe at ymail.com
Wed Mar 23 10:31:59 CET 2011

Hi Alan,
Im new to freeRADIUS, trying to implement it for my test machine running currently on Ubuntu 9.04 Server.Im trying to establish a communication between Windows XP,SP3 client and RADIUS SERVER ( on Ubuntu Server) through EAP/TLS and cerrtificates.
The problem i m facing is, when i run the server in debug mode it gives me this warning - 
Module: Linked to sub-module rlm_eap_md5
 Module: Instantiating eap-md5
 Module: Linked to sub-module rlm_eap_leap
 Module: Instantiating eap-leap
 Module: Linked to sub-module rlm_eap_gtc
 Module: Instantiating eap-gtc
   gtc {
        challenge = "Password: "
        auth_type = "PAP"
Ignoring EAP-Type/tls because we do not have OpenSSL support.
Ignoring EAP-Type/ttls because we do not have OpenSSL support.
Ignoring EAP-Type/peap because we do not have OpenSSL support.
 Module: Linked to sub-module rlm_eap_mschapv2
 Module: Instantiating eap-mschapv2
   mschapv2 {
        with_ntdomain_hack = no
 I tried to install the patch available for OpenSSL, but the error still persists. 
Also, i tried to run the rlm_eap_ttls.c file but the error i get is --
root at ubuntu:/etc/freeradius-2.1.9+dfsg/src/modules/rlm_eap/types/rlm_eap_ttls# ./configure
checking for OpenSSL support... no
configure: WARNING: silently not building rlm_eap_ttls.
configure: WARNING: FAILURE: rlm_eap_ttls requires: OpenSSL.
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: config.h is unchanged
It would be great if you can help me get through this issue.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20110323/a902fec4/attachment.html>

More information about the Freeradius-Users mailing list