Subject: Re: freeradius 2 certificate compatibility issue with ubuntu

Dustin S dsoodak at
Mon May 2 21:09:29 CEST 2016

Message-ID: <20160430132627.GA10793 at>
Content-Type: text/plain; charset=us-ascii

>> p.s.: using v2 since v3 isn't supported on Ubuntu yet. After a full week of trying both the unofficial release and attempting to compile it myself, I realized that I don't know anywhere near enough about freeradius to debug it properly.

>v3 is supported on Ubuntu  - I've installed it on 14.x, 15.x and 16.x servers. 

Maybe you can help my get past the part that held me up (for most of a week) the last several times I tried to install this version.

I did the following and everything went fine (generating the large prime took several minutes):
  apt-add-repository ppa:freeradius/stable-3.0
  apt-get update
  apt-get install freeradius make
Then, after making sure all the necessary utilities were installed:

  sudo apt-get install freeradius freeradius-mysql freeradius-utils
and creating a test user, I started it with "freeradius -X" and the following tests all gave me "Access-Accept" (the third one wouldn't work for my freeradius2):
  radtest bob h3llo localhost 1812 t3sting123
  radtest -t mschap bob h3llo localhost 100 t3sting123
  radtest -t eap-md5 bob h3llo localhost 100 t3sting123

The problem I had is that I could never get the database to work.

I installed extra mysql stuff I remembered needing for v2:

  sudo apt-get install mysql-server
  sudo apt-get install libmysqlclient-dev
Then added a database "radius", and imported its tables and user:
  mysql -u root -p radius < /etc/freeradius/mods-config/sql/main/mysql/schema.sql
  mysql -u root -p < /etc/freeradius/mods-config/sql/main/mysql/setup.sql
And added a test user:  
INSERT INTO radcheck (UserName, Attribute, op, Value) VALUES ('bobsql', 'Password', ':=', 'h3llo');

Now, the manual at says to open "/etc/raddb/radiusd.conf" and "$INCLUDE  sql.conf", but "sql.conf" isn't in this version. It also says to edit "/etc/raddb/sql.conf" and the "raddb" directory doesn't even exist on my computer.

I tried cross referencing this with other sites (and made much use of "grep" and "find"), but nothing worked. Installing daloradius seemed to fix the problem but it came back the next day.


More information about the Freeradius-Users mailing list