authentication request failed for SSH using freeradius server.

Alan DeKok aland at
Thu Jun 28 02:29:17 CEST 2018

On Jun 27, 2018, at 7:14 PM, Hailun Tan <dearambermini at> wrote:
> I tried your advice to change the /etc/pam.d/sshd, reboot the ssh service
> with "sudo service ssh restart".

  This list is not the place to discuss PAM configuration, or PAM debugging.

> I have solved this problem by manipulating the  NSS  on the  radius client
> to refer to the MySQL database, which is used by radius server for user
> name/password storage.

  Which has nothing to do with RADIUS or FreeRADIUS.

> I know the above solution is not directly related to radius.  But anyone
> working on radius could likely to encounter this issue and saying " this
> issue has nothing to do with  radius/free radius/" would
> not help.

  Exactly. What DOES help is telling you to ask the PAM people how to fix their software.

  What DOES help is me telling you that you needed to configure NSS.  Which is what I did.

  This isn't a complicated concept.  You were having problems with PAM.  You were told to go ask the PAM people.  Instead of doing that, you asked the same questions here over and over and over and over again.

  What REALLY doesn't help is snarky comments about how to better help people.  The only thing preventing you from solving the problem earlier was your refusal to follow instructions.

  Now stop posting about PAM issues.  Or else.

  Alan DeKok.

More information about the Freeradius-Users mailing list