Not able to enable/install extension module python with freeradius

Tara Khoiwal (tkhoiwal) tkhoiwal at
Thu May 7 10:44:41 CEST 2020


I could resolve my previous issue where server was not coming up completely. There were few configs in eap module which I disabled, and it worked fine.

Now I am facing issue with python module load. It is giving following error:

Python version: 2.7.5 (default, Apr  2 2020, 13:16:51)  [GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]

python_function_load - Module 'example' not found

<type 'exceptions.ImportError'> (No module named example)

python_function_load - Failed to import python function 'example.post_auth'

/usr/local/etc/raddb/mods-enabled/python[9]: Instantiation failed for module "python"

I have attached complete debug logs of server. Any pointers/suggestions to resolve this issue would be great help.


From: Jorge Pereira <jpereira at>
Date: Thursday, 7 May 2020 at 1:12 AM
To: FreeRadius users mailing list <freeradius-users at>
Cc: "Tara Khoiwal (tkhoiwal)" <tkhoiwal at>
Subject: Re: Not able to enable/install extension module python with freeradius

It would be helpful if you share the debug output.

Jorge Pereira
jpereira at<mailto:jpereira at>

On 6 May 2020, at 09:10, Tara Khoiwal (tkhoiwal) via Freeradius-Users <freeradius-users at<mailto:freeradius-users at>> wrote:

Thank you Alan for your quick response. Yes, I did changes to default configuration to enable EAP-TLS authentication and add python module for post-auth checks. I reverted those configurations and ran the server. It is running fine. I need to check my configurations for EAP-TLS again.

Is there a way to install specific extensions on top of already installed freeradius package? I will also check on the reference you have provided for latest packages.


On 06/05/20, 5:19 PM, "Freeradius-Users on behalf of Alan DeKok" < at< at> on behalf of aland at<mailto:aland at>> wrote:

   On May 6, 2020, at 7:08 AM, Tara Khoiwal (tkhoiwal) via Freeradius-Users <freeradius-users at<mailto:freeradius-users at>> wrote:

I have installed freeradius 3.0.18 as per the instruction mentioned in the freeradius guide on building and installing from source code. After installation I tried running server. But server did not start completely and not seeing message “Ready to process requests”.

     That is a very unusual error.  I don't recall ever seeing that before.

     Did you change *anything* in the default configuration?

I have attached the server log.

     It's better to attach files as text, or to just paste them into the message.

Kindly help me to resolve the issue. I also tried installing freeradius with yum package installer. However, with that distribution python module is not available. Can I only install specific module? It will be great if you can guide me on either resolve issue with freeradius install from source code or install extensions separately.

     Full packages are available here:

     They include everything, and are for the latest release.

     Alan DeKok.

   List info/subscribe/unsubscribe? See

List info/subscribe/unsubscribe? See

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: debugfile.txt
URL: <>

More information about the Freeradius-Users mailing list