Commit report for master branch
New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== dhcpclient: Load dictionary.dhcp from DICTDIR. Load dictionary.dhcp from DICTDIR instead of RADDBDIR in dhcpclient.c, as it is found only in the former. This fixes the following error printed when invoking dhcpclient: Failed reading dictionary.dhcp: dict_init: Couldn't open dictionary "/etc/raddb/dictionary.dhcp": No such file or directory Nikolai Kondrashov (via Alan T. DeKok)@2014-10-06T16:31:11Z Files modified: * src/modules/proto_dhcp/dhcpclient.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/5c0995336cac8d8a83030... ====== Clean up fr_pow() Alan T. DeKok@2014-10-06T15:21:44Z Files modified: * src/modules/rlm_expr/rlm_expr.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/cd93756390318bea87e58... ====== Parse perlconf before running the initialization subroutine Alan T. DeKok@2014-10-06T15:13:44Z Files modified: * src/modules/rlm_perl/rlm_perl.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/926d58ffc9e06158e9339... ====== move fr_pow to rlm_expr. No one else uses it. Alan T. DeKok@2014-10-06T02:45:49Z Files modified: * src/include/libradius.h * src/lib/misc.c * src/modules/rlm_expr/rlm_expr.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c5e13e5c14de8685f0563... ====== Change ! to ~, as that's what it really is. Alan T. DeKok@2014-10-06T02:41:33Z Files modified: * raddb/mods-available/expr * src/modules/rlm_expr/rlm_expr.c * src/tests/keywords/expr Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/b00af9618cf6677cabef1... ====== Allow cast of ifid to integer64 Alan T. DeKok@2014-10-06T02:41:32Z Files modified: * src/main/evaluate.c * src/main/parser.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ffc4b1955505f3d25223f... ====== Use attribute references instead of string expansions. Which skips a few steps of xlat. If the attribute doesn't exist, it's value defaults to zero Alan T. DeKok@2014-10-06T02:41:30Z Files modified: * raddb/policy.d/accounting Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/733dc4468e9d5f89408e4... ====== More descriptive error message Alan T. DeKok@2014-10-06T02:41:29Z Files modified: * src/modules/rlm_expr/rlm_expr.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/a12204b7e3d72e4503139... ====== Use shift and OR instead of multiplication by magic number Alan T. DeKok@2014-10-06T02:41:28Z Files modified: * raddb/policy.d/accounting Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/072ba408fdf9368e0ed07... ====== Remove unused variable Alan T. DeKok@2014-10-06T02:41:24Z Files modified: * src/main/modcall.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1283a0cd11411be6ba6bb... ====== -- This commit summary was generated @2014-10-07T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).
participants (1)
-
announceļ¼ freeradius.org