New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Add function to create unknown attributes from text strings Arran Cudbard-Bell@2013-02-12T21:17:52Z Files modified: * src/include/libradius.h * src/lib/dict.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/6d19c4d18c28fb8c84431... ====== Fix indentation in pairparsevalue Arran Cudbard-Bell@2013-02-12T20:20:46Z Files modified: * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/2b9efa65fbd0de7b944f5... ====== Additional dictionary functions for working with dynamic attributes Arran Cudbard-Bell@2013-02-12T20:20:46Z Files modified: * src/include/libradius.h * src/lib/dict.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/21612addf4189cfd7d1ba... ====== Actually print out encoded options in debug mode. Alan T. DeKok@2013-02-12T20:18:25Z Files modified: * src/lib/dhcp.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d1ec0730b6fc003300a5c... ====== As found on the net Alan T. DeKok@2013-02-12T20:16:36Z Files modified: * share/dictionary * share/dictionary.zeus Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/9d9e96287739b31f2d5ae... ====== Added radmin command "hup main.log". Closes issue #121 Alan T. DeKok@2013-02-12T20:16:19Z Files modified: * src/include/radiusd.h * src/main/command.c * src/main/mainconfig.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/928cffed328fb33f749fa... ====== Clarify decoding code Alan T. DeKok@2013-02-12T19:47:06Z Files modified: * src/lib/radius.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/28ecdec08dd838431e398... ====== Added dict_attrbytype(attr, vendor, type) for dealing with combo-ip attributes Alan T. DeKok@2013-02-12T19:46:32Z Files modified: * src/include/libradius.h * src/lib/dict.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/22d0dc7cae53098300b15... ====== Use hard-coded numbers for dictionary entries. There's no reason to expect that the server binary will be incompatible with the dictionaries Alan T. DeKok@2013-02-12T16:35:00Z Files modified: * src/modules/rlm_cache/rlm_cache.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/659697aeb14b81c2184d0... ====== Rename unknown_attr to is_unkown (like is_tlv) Arran Cudbard-Bell@2013-02-12T15:56:18Z Files modified: * src/include/libradius.h * src/lib/dict.c * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/9d4fc70c4da8357dc70b9... ====== Ignore warnings.txt (output of make warnings) Arran Cudbard-Bell@2013-02-12T15:56:17Z Files modified: * .gitignore Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/14a38412233f6d4cb2355... ====== Check return code of dict_addattr, and use correct argument order and print a useful error message Alan T. DeKok@2013-02-12T15:30:10Z Files modified: * src/modules/rlm_sql/rlm_sql.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/eca49611ca7b37419f9f5... ====== Added "default" to switch statement Alan T. DeKok@2013-02-12T02:45:46Z Files modified: * src/lib/print.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c779df5d7d13f5dd4f3c4... ====== Add dict_attrunknown function for when we don't have dictionary entries but still need to assign a DA to a VP. Arran Cudbard-Bell@2013-02-12T02:37:17Z Files modified: * src/include/libradius.h * src/lib/dict.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/957801d9254145af6b4cb... ====== Decode extended TLVs correctly. This uses the new dict_attrbyparent() API to avoid doing magic on "nest". The code becomes a bit easier to read. Alan T. DeKok@2013-02-12T01:36:39Z Files modified: * src/lib/radius.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/4d301538ffb1411260014... ====== VP_TRACE using hex values for VID / attr It's easier to read Alan T. DeKok@2013-02-12T01:36:39Z Files modified: * src/lib/radius.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1855d2e95b23e9bbe39ad... ====== Look for extended attrs before RFC format ones Alan T. DeKok@2013-02-12T01:36:39Z Files modified: * src/lib/radius.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d840147b88f619fbd553a... ====== Added dict_attrbyparent() Which gets a DICT_ATTR based on a parent reference, and an attr number This is so that any magic of playing with attr/vendor is hidden inside of one function, rather than being in multiple places Alan T. DeKok@2013-02-12T01:36:39Z Files modified: * src/include/libradius.h * src/lib/dict.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8bdf152294d5c73a6a7e9... ====== Refer to cache_eap authorize method, not authenticate Alan T. DeKok@2013-02-12T01:36:39Z Files modified: * raddb/policy.d/eap Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/fb2049ecdaf2b490abaa5... ====== Enable cache_eap module by default Alan T. DeKok@2013-02-12T01:36:39Z Files modified: * raddb/Makefile Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/9a08506f0bde5b2307e59... ====== Define value types as an enum Arran Cudbard-Bell@2013-02-12T01:07:07Z Files modified: * src/include/libradius.h * src/include/radius.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/6488df80d7bb188e7c330... ====== -- This commit summary was generated @2013-02-13T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).
participants (1)
-
announceļ¼ freeradius.org