Commit report for v3.0.x branch
New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== %d for macros holding size Alan T. DeKok@2015-05-04T14:10:34Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8c3feb01511484a12ad99... ====== Use sizeof header, to be the same as the later comparison Alan T. DeKok@2015-05-04T13:56:26Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ceb069294b57f0160ca1e... ====== Use memcpy() when writing to binary buffers Alan T. DeKok@2015-05-04T13:56:25Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/a44a3c2defccb57ca1a0a... ====== Check peer confirm length before dereferencing it Alan T. DeKok@2015-05-04T13:56:24Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/92ce546a15c03739daffe... ====== Check packet length before dereferencing fields Alan T. DeKok@2015-05-04T13:56:24Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d6fb7762514e17ee56b02... ====== Add "len" field to peer commit And check length of packet from peer before decoding it. Alan T. DeKok@2015-05-04T13:56:23Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.c * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.h * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/aad3901dac119509ad1c8... ====== Use "in" instead of "in_buf" and "buf" Alan T. DeKok@2015-05-04T13:56:22Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.h * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c00bc46c4acf864f99266... ====== No need for a separate conf structure Alan T. DeKok@2015-05-04T13:56:21Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/0bd1debb4203ced26e313... ====== Just to be explicit Alan T. DeKok@2015-05-04T13:56:20Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/dc919f118a6412e82db15... ====== Use consistent names for packets Alan T. DeKok@2015-05-04T13:56:19Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.h * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/653badd6b32aefc97492f... ====== mtu is size_t. And if we're doing what EAP-TLS does, then be sure to do the same thing. Alan T. DeKok@2015-05-04T13:56:18Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.h * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/61ead823ed5cb7bc6f050... ====== Rename "offset" to "mtu", which is more accurate Alan T. DeKok@2015-05-04T13:56:17Z Files modified: * src/include/tls-h * src/main/tls.c * src/main/tls_listen.c * src/modules/rlm_eap/libeap/eap_tls.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d0d88c45d396f1ae1064f... ====== Use consistent names everywhere Alan T. DeKok@2015-05-04T13:56:16Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.c * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/0c2f5ed04631b5bfa923a... ====== -- This commit summary was generated @2015-05-05T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).
participants (1)
-
announceļ¼ freeradius.org