Commit report for v3.1.x branch
New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Compile maps and run tests on them Alan T. DeKok@2015-05-04T22:55:25Z Files modified: * src/main/modcall.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/00a0f3963fa7841246456... ====== Check the destination lists only for "update" sections for maps, the second argument is a module, not a list Alan T. DeKok@2015-05-04T22:54:52Z Files modified: * src/main/map.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/81baadc5d72917140f1cf... ====== Parse "map" things, and expose functions for manipulation Alan T. DeKok@2015-05-04T22:54:06Z Files modified: * src/include/conffile.h * src/main/conffile.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/fdfb9b6bea8e012a1e99a... ====== %d for macros holding size Alan T. DeKok@2015-05-04T14:10:50Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1c0f33465033cd321a256... ====== Use sizeof header, to be the same as the later comparison Alan T. DeKok@2015-05-04T13:58:13Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/2ec2b4b173045daeed58a... ====== Use memcpy() when writing to binary buffers Alan T. DeKok@2015-05-04T13:58:13Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1add80ce6788e677fe985... ====== Check peer confirm length before dereferencing it Alan T. DeKok@2015-05-04T13:58:11Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/96565c1b3524e3f7dc367... ====== Check packet length before dereferencing fields Alan T. DeKok@2015-05-04T13:58:11Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/6e4daf93d96de34463d12... ====== Add "len" field to peer commit And check length of packet from peer before decoding it. Alan T. DeKok@2015-05-04T13:58:10Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.c * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.h * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/a115bfbacd7da11db95fc... ====== Use "in" instead of "in_buf" and "buf" Alan T. DeKok@2015-05-04T13:58:09Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.h * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/05c6c1070c05aa4fa2152... ====== No need for a separate conf structure Alan T. DeKok@2015-05-04T13:58:07Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/e382bf7b2ed5d10dbcbb7... ====== Just to be explicit Alan T. DeKok@2015-05-04T13:58:03Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/7ecdc115b1127b144b4f1... ====== Use consistent names for packets Alan T. DeKok@2015-05-04T13:58:02Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.h * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/e87b581527f95169519b2... ====== mtu is size_t. And if we're doing what EAP-TLS does, then be sure to do the same thing. Alan T. DeKok@2015-05-04T13:58:01Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.h * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/92b79686705ba14599ee3... ====== Rename "offset" to "mtu", which is more accurate Alan T. DeKok@2015-05-04T13:57:59Z Files modified: * src/include/tls-h * src/main/tls.c * src/main/tls_listen.c * src/modules/rlm_eap/libeap/eap_tls.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/3a45ff590ba0d382e813f... ====== Use consistent names everywhere Alan T. DeKok@2015-05-04T13:57:50Z Files modified: * src/modules/rlm_eap/types/rlm_eap_pwd/eap_pwd.c * src/modules/rlm_eap/types/rlm_eap_pwd/rlm_eap_pwd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/565ca1d3f9826e560a4b0... ====== -- This commit summary was generated @2015-05-05T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).
participants (1)
-
announceļ¼ freeradius.org