Commit report for v3.0.x branch
New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Note recent changes Alan T. DeKok@2014-10-10T21:51:03Z Files modified: * doc/ChangeLog Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/89219b2d09e938632efe5... ====== Fix compiler warning Alan T. DeKok@2014-10-10T21:44:06Z Files modified: * src/main/client.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/b1f7cd47d21e3ade53915... ====== Allow CoA packets to be proxied via Packet-Dst-IP-Address Alan T. DeKok@2014-10-10T21:38:41Z Files modified: * src/main/process.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8e008c8b425bf295171c7... ====== Allow CoA packets to be read from the detail file Alan T. DeKok@2014-10-10T21:08:46Z Files modified: * src/main/detail.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/adf44983df6ef4d6c9f0f... ====== Expose rad_coa_recv Alan T. DeKok@2014-10-10T21:08:46Z Files modified: * src/include/radiusd.h * src/main/listen.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/884e7c3327a2e9c390307... ====== Set packet->code from Packet-Type in detail file but still force everything to be accounting packets. We'll need a separate rad_coa() function to handle reading coa packets from the detail file reader Alan T. DeKok@2014-10-10T21:08:46Z Files modified: * src/main/detail.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d9ca0a04a590473518c63... ====== Add tracking when reading detail files. So that we process each packet once, and only once Alan T. DeKok@2014-10-10T21:08:46Z Files modified: * raddb/mods-available/detail * src/include/detail.h * src/main/detail.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/60ab352b52abc3de9a8a3... ====== Write timestamps even in non-compat mode Alan T. DeKok@2014-10-10T21:08:46Z Files modified: * src/modules/rlm_detail/rlm_detail.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/7def6cd9fa58db26ecd90... ====== Rename vpt_types to tmpl_types Arran Cudbard-Bell@2014-10-10T04:13:07Z Files modified: * src/include/tmpl.h * src/main/valuepair.c * src/modules/rlm_cache/rlm_cache.c * src/modules/rlm_ldap/attrmap.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1cbece65b8064506fe04c... ====== -- This commit summary was generated @2014-10-11T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).
participants (1)
-
announceļ¼ freeradius.org