Commit report for v3.0.x branch
New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Arg no longer used Arran Cudbard-Bell@2014-01-21T23:57:34Z Files modified: * src/modules/rlm_rest/rest.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/aaad2442018cfadde8655... ====== Update ChangeLog Arran Cudbard-Bell@2014-01-21T23:54:30Z Files modified: * doc/ChangeLog Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/4f7ddf75944fb11bedc43... ====== Missed break Arran Cudbard-Bell@2014-01-21T23:42:43Z Files modified: * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/f6d7584ab3968736e3a18... ====== Doxygen Arran Cudbard-Bell@2014-01-21T23:40:54Z Files modified: * src/main/log.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/fbe1fff63496451761d02... ====== Fixup format strings Arran Cudbard-Bell@2014-01-21T23:37:59Z Files modified: * src/main/process.c * src/modules/rlm_eap/eap.c * src/modules/rlm_eap/rlm_eap.c * src/modules/rlm_ldap/ldap.c * src/modules/rlm_mschap/opendir.c * src/modules/rlm_mschap/rlm_mschap.c * src/modules/rlm_rest/rest.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/26d9f62f0993075a7d4ce... ====== Fix operation of fr_strerror() A while back a flag was added to fr_strerror() to stop the same error message being output multiple times (and leading to confusing debug output). Unfortunately the macro for RERROR() and pals, inadvertently called fr_strerror() multiple times as ## __VA_ARGS__ was passed both to module_failure_msg() and radlog_request(), with the arguments to the macro being evaluated once per call. The solution is to switch the logging functions to use va_list instead of the ellipses, add a helper to convert ## __VA_ARGS__ into va_list, and then use va_copy to create a copy of the arguments for the radlog_request() call. As a side effect, it appears to of enabled printf format validation for more macros, so the next commit will be to fix all the places where that was previously unreported... Arran Cudbard-Bell@2014-01-21T23:37:59Z Files modified: * src/include/log.h * src/include/radiusd.h * src/main/log.c * src/main/process.c * src/main/unittest.c * src/main/util.c * src/main/valuepair.c * src/main/xlat.c * src/modules/rlm_eap/radeapclient.c * src/modules/rlm_sqlhpwippool/rlm_sqlhpwippool.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d253c7306dc5170972dc7... ====== Formatting and extra error messages Arran Cudbard-Bell@2014-01-21T23:37:59Z Files modified: * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/bb8c62240a7cd31fc1043... ====== Unsigned comes after "int" Alan T. DeKok@2014-01-21T20:41:03Z Files modified: * raddb/mods-config/sql/main/mysql/schema.sql Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/30d0f2e9351d40663898c... ====== reconnect can be called with an unused connection handle. Fixes #507 Alan T. DeKok@2014-01-21T20:39:40Z Files modified: * src/main/connection.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d89cdb253465f953a6ce6... ====== Fix scan warnings Alan T. DeKok@2014-01-21T19:14:50Z Files modified: * src/main/conffile.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/30fc7ef4fa4d3dd2d6e40... ====== Remove unused assignment Alan T. DeKok@2014-01-21T19:14:50Z Files modified: * src/main/radattr.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/36149d2dbb31172f9adcc... ====== Add comparisons for SIGNED and ETHERNET types Conflicts: src/lib/valuepair.c Arran Cudbard-Bell@2014-01-21T13:54:07Z Files modified: * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/5580706cba07996716427... ====== Do NOT just return 0 silently if we don't support the type in paircmp, that's a great way to mess up any trees which use the function Arran Cudbard-Bell@2014-01-21T13:53:20Z Files modified: * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/690b3f057af014e1ce3c3... ====== Fix merge issue... Arran Cudbard-Bell@2014-01-21T10:38:07Z Files modified: * share/dictionary.h3c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1f3e57d28795843df0d8d... ====== Extend the H3C dictionary based on public manuals Try to extend the H3C dictionary based on what is scattered on their pages. At least most of it is found quite consistently in the product-specific "Security Configuration Guides". This compilation/crosschecking is based H3C documentation for listed devices: - H3C S12500 and S6800 Switches - H3C WA WLAN Access Points - H3C MSR Routers Remarks: Does not stick with H3C's use of of underline in attribute naming. Conflicts: share/dictionary.h3c Mathieu Simon (via Arran Cudbard-Bell)@2014-01-21T10:02:09Z Files modified: * share/dictionary.h3c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d7d7670a1a9ad2e1de195... ====== -- This commit summary was generated @2014-01-22T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).
participants (1)
-
announceļ¼ freeradius.org