Commit report for v3.0.x branch
New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Update warning for clients Arran Cudbard-Bell@2014-05-30T23:35:21Z Files modified: * src/main/client.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/0f71ca4b091c78781ffd2... ====== Add similar ipaddr, ipv4addr, ipv6addr config items for realms Arran Cudbard-Bell@2014-05-30T23:35:21Z Files modified: * src/main/realms.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/90f508167e163cdc0cc58... ====== Add similar ipaddr, ipv4addr, ipv6addr config items for listen sections Arran Cudbard-Bell@2014-05-30T23:29:36Z Files modified: * src/main/listen.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/daa02e0268e58efa7d84b... ====== Rename PW_TYPE_IP* so they're all consistent Arran Cudbard-Bell@2014-05-30T23:06:14Z Files modified: * src/include/conffile.h * src/include/radius.h * src/lib/dict.c * src/lib/print.c * src/lib/radius.c * src/lib/valuepair.c * src/main/client.c * src/main/command.c * src/main/conffile.c * src/main/evaluate.c * src/main/listen.c * src/main/parser.c * src/main/realms.c * src/main/valuepair.c * src/main/xlat.c * src/modules/proto_dhcp/dhcp.c * src/modules/proto_dhcp/dhcpd.c * src/modules/proto_vmps/vqp.c * src/modules/rlm_eap/types/rlm_eap_ttls/ttls.c * src/modules/rlm_example/rlm_example.c * src/modules/rlm_ippool/rlm_ippool.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/a6da7594d1ae0a80092d3... ====== Add PW_TYPE_COMBO_IP_PREFIX (conffile parser only) Change 'ipaddr' to PW_TYPE_COMBO_IP_PREFIX so we can be really lazy about IP formats Arran Cudbard-Bell@2014-05-30T22:27:56Z Files modified: * src/include/conffile.h * src/include/radius.h * src/lib/radius.c * src/lib/valuepair.c * src/main/client.c * src/main/conffile.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d771cb415d321ed0f2a68... ====== Rename fr_pton functions to fr_pton4, fr_pton6 and fr_pton. fr_pton will resolve the IP address to either 4 or 6 based on format and/or available DNS records. Arran Cudbard-Bell@2014-05-30T21:58:09Z Files modified: * src/include/libradius.h * src/lib/misc.c * src/lib/valuepair.c * src/main/client.c * src/main/command.c * src/main/conffile.c * src/main/detail.c * src/main/mainconfig.c * src/main/radclient.c * src/main/radiusd.c * src/main/radmin.c * src/main/realms.c * src/modules/proto_dhcp/dhcpclient.c * src/modules/rlm_eap/radeapclient.c * src/modules/rlm_sqlippool/rlm_sqlippool.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/06b384abeff9e2de2154c... ====== Update ChangeLog Arran Cudbard-Bell@2014-05-30T19:27:13Z Files modified: * doc/ChangeLog Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1b8abb31b51eb3c080f9b... ====== Fix issue where use of FreeRADIUS-Client-IPv6-Prefix and FreeRADIUS-Client-IPv4-Prefix when creating dynamic client entries, would trigger an error. Arran Cudbard-Bell@2014-05-30T19:17:20Z Files modified: * src/main/client.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/b628f5e4a830453cddf6a... ====== Minor typos in error messages Arran Cudbard-Bell@2014-05-30T19:10:31Z Files modified: * src/main/client.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d21ae007041696541bca1... ====== Switch to using fr_ipaddr_t for client prefixes, and allow ipaddr and ipaddr6 config items to be prefixes. Addresses #581. Arran Cudbard-Bell@2014-05-30T18:57:29Z Files modified: * src/include/radiusd.h * src/main/client.c * src/main/command.c * src/main/detail.c * src/main/stats.c * src/modules/proto_dhcp/dhcpd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/995839750eb943efa8910... ====== Add fr_ipaddr_mask to fixup fr_ipaddr_t's by zeroing out the host portion of the address Arran Cudbard-Bell@2014-05-30T18:57:29Z Files modified: * src/include/libradius.h * src/lib/misc.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c138cb014ee736b462c4f... ====== Add nonnull hint Arran Cudbard-Bell@2014-05-30T18:49:06Z Files modified: * src/include/radiusd.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c8f168e3265d6b76d89ae... ====== Add fr_ptonx, fr_ntop and is_wildcard IP address functions Arran Cudbard-Bell@2014-05-30T18:49:06Z Files modified: * src/include/libradius.h * src/lib/misc.c * src/main/mainconfig.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/21aa6678a770669ba72ca... ====== Simplify masking Arran Cudbard-Bell@2014-05-30T18:49:06Z Files modified: * src/lib/misc.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c3a494eb56446354273cd... ====== Whitespace changes Arran Cudbard-Bell@2014-05-30T17:28:09Z Files modified: * src/main/client.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/deb1c55eb1487de056471... ====== Merge pull request #672 from spbnick/init_delay_rename_v3.0.x Rename min_response_window to init_delay - v3.0.x Alan DeKok@2014-05-30T17:05:20Z Files modified: * src/include/radiusd.h * src/main/mainconfig.c * src/main/process.c * src/main/realms.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/6ccedce6b4c78e0b2f4e2... ====== Rename min_response_window to init_delay Rename main_config's "min_response_window" field to "init_delay", as it better reflects the usage and because its value won't be related to any response window in case they're all higher than 1/3 s, which is true most of the time. Nikolai Kondrashov@2014-05-30T16:41:22Z Files modified: * src/include/radiusd.h * src/main/mainconfig.c * src/main/process.c * src/main/realms.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/702138033f59f89dafdd2... ====== Add FR_TIMEVAL_BOUND_CHECK Add FR_TIMEVAL_BOUND_CHECK implementing bounding for struct timeval values, similarly to FR_INTEGER_BOUND_CHECK. Use it in home_server_add and client_parse to increase readability. Nikolai Kondrashov (via Alan T. DeKok)@2014-05-30T14:39:10Z Files modified: * src/include/conffile.h * src/main/client.c * src/main/realms.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c8db68c8fcf8e32c93c4b... ====== Fix all remaining config items to use FR_CONF_OFFSET Add support to the conffile parser for parsing IPv4 addresses in octal and hex format Add support to conffile parser for parsing prefix type config items Standardise on using fr_ipaddr_t structures to represent IP addresses in the conffile code, and other places. Arran Cudbard-Bell@2014-05-30T13:21:31Z Files modified: * src/include/conffile.h * src/include/radiusd.h * src/include/stats.h * src/main/client.c * src/main/conffile.c * src/main/connection.c * src/main/listen.c * src/main/radwho.c * src/main/realms.c * src/main/threads.c * src/modules/proto_dhcp/dhcpd.c * src/modules/rlm_eap/types/rlm_eap_ikev2/rlm_eap_ikev2.c * src/modules/rlm_example/rlm_example.c * src/modules/rlm_ippool/rlm_ippool.c * src/modules/rlm_passwd/rlm_passwd.c * src/modules/rlm_python/rlm_python.c * src/modules/rlm_rest/rlm_rest.c * src/modules/rlm_ruby/rlm_ruby.c * src/modules/rlm_unix/rlm_unix.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8ac45a9b8fd59f583d023... ====== Break out IP parsing into fr_pton and fr_pton6. Any function which needs to parse IP addresses or IP prefixes in the server should be accommodated by these functions. Arran Cudbard-Bell@2014-05-30T02:28:58Z Files modified: * src/include/libradius.h * src/lib/misc.c * src/lib/valuepair.c * src/main/client.c * src/main/command.c * src/main/conffile.c * src/main/detail.c * src/main/radclient.c * src/main/radiusd.c * src/main/radmin.c * src/main/realms.c * src/modules/proto_dhcp/dhcpclient.c * src/modules/rlm_eap/radeapclient.c * src/modules/rlm_sqlippool/rlm_sqlippool.c * src/tests/unit/rfc.txt Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/5440516a76bf4ba266f98... ====== -- This commit summary was generated @2014-05-31T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).
participants (1)
-
announceļ¼ freeradius.org