Commit report for v3.1.x branch
New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Only store the module's module_t pointer in module_instance_t This reduces the number of dereferences and makes the code clearer Arran Cudbard-Bell@2015-12-20T23:55:30Z Files modified: * src/include/modpriv.h * src/main/command.c * src/main/interpreter.c * src/main/mainconfig.c * src/main/modcall.c * src/main/modules.c * src/main/unittest.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d665d6006d9033d0d240d... ====== s/mi/instance/ in more places Arran Cudbard-Bell@2015-12-20T23:15:52Z Files modified: * src/main/mainconfig.c * src/main/unittest.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/3380fca4acbd1c3013ba7... ====== s/mi/instance/ Arran Cudbard-Bell@2015-12-20T23:15:05Z Files modified: * src/main/command.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/85d850cfc07df53cb1ca4... ====== s/module_interface_t/module_t/ Arran Cudbard-Bell@2015-12-20T23:09:27Z Files modified: * src/include/modpriv.h * src/include/modules.h * src/main/command.c * src/main/modules.c * src/modules/proto_dhcp/rlm_dhcp.c * src/modules/rlm_always/rlm_always.c * src/modules/rlm_attr_filter/rlm_attr_filter.c * src/modules/rlm_cache/rlm_cache.c * src/modules/rlm_chap/rlm_chap.c * src/modules/rlm_couchbase/rlm_couchbase.c * src/modules/rlm_cram/rlm_cram.c * src/modules/rlm_csv/rlm_csv.c * src/modules/rlm_date/rlm_date.c * src/modules/rlm_detail/rlm_detail.c * src/modules/rlm_digest/rlm_digest.c * src/modules/rlm_dynamic_clients/rlm_dynamic_clients.c * src/modules/rlm_eap/rlm_eap.c * src/modules/rlm_example/rlm_example.c * src/modules/rlm_exec/rlm_exec.c * src/modules/rlm_expiration/rlm_expiration.c * src/modules/rlm_expr/rlm_expr.c * src/modules/rlm_files/rlm_files.c * src/modules/rlm_idn/rlm_idn.c * src/modules/rlm_json/rlm_json.c * src/modules/rlm_krb5/rlm_krb5.c * src/modules/rlm_ldap/rlm_ldap.c * src/modules/rlm_linelog/rlm_linelog.c * src/modules/rlm_logintime/rlm_logintime.c * src/modules/rlm_mschap/rlm_mschap.c * src/modules/rlm_opendirectory/rlm_opendirectory.c * src/modules/rlm_otp/rlm_otp.c * src/modules/rlm_pam/rlm_pam.c * src/modules/rlm_pap/rlm_pap.c * src/modules/rlm_passwd/rlm_passwd.c * src/modules/rlm_perl/rlm_perl.c * src/modules/rlm_preprocess/rlm_preprocess.c * src/modules/rlm_python/rlm_python.c * src/modules/rlm_radutmp/rlm_radutmp.c * src/modules/rlm_realm/rlm_realm.c * src/modules/rlm_redis/rlm_redis.c * src/modules/rlm_redis_ippool/rlm_redis_ippool.c * src/modules/rlm_rediswho/rlm_rediswho.c * src/modules/rlm_replicate/rlm_replicate.c * src/modules/rlm_rest/rlm_rest.c * src/modules/rlm_ruby/rlm_ruby.c * src/modules/rlm_securid/rlm_securid.c * src/modules/rlm_smsotp/rlm_smsotp.c * src/modules/rlm_soh/rlm_soh.c * src/modules/rlm_sometimes/rlm_sometimes.c * src/modules/rlm_sql/rlm_sql.c * src/modules/rlm_sqlcounter/rlm_sqlcounter.c * src/modules/rlm_sqlhpwippool/rlm_sqlhpwippool.c * src/modules/rlm_sqlippool/rlm_sqlippool.c * src/modules/rlm_test/rlm_test.c * src/modules/rlm_unbound/rlm_unbound.c * src/modules/rlm_unix/rlm_unix.c * src/modules/rlm_unpack/rlm_unpack.c * src/modules/rlm_utf8/rlm_utf8.c * src/modules/rlm_wimax/rlm_wimax.c * src/modules/rlm_yubikey/rlm_yubikey.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/288664df2e033c2ba43c8... ====== s/module_t/module_dl_t/ Arran Cudbard-Bell@2015-12-20T23:08:48Z Files modified: * doc/developer/module_interface.rst * src/include/modpriv.h * src/main/modules.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/7a08ab440048dd756227c... ====== Merge pull request #1459 from herwinw/rlm_python_fixes Rlm python fixes Arran Cudbard-Bell@2015-12-20T22:14:20Z Files modified: * src/modules/rlm_python/prepaid.py * src/modules/rlm_python/radiusd.py * src/modules/rlm_python/rlm_python.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/fc566c9da58cbdf79476e... ====== Allow strings as operator in rlm_python Because ('Tmp-String-0', '!*', 'ANY') is just so more readable than ('Tmp-String-0', 21, 'ANY'). Plain integers still work for backwards compatibility. As a bonus, we get rid of the OP table in radiusd.py: this module was not supposed to be included in scripts running from FreeRADIUS, but was still referenced from prepaid.py. As a bonus, we get rid of a table that was no longer in sync with the definitions in tokens.h. Herwin Weststrate@2015-12-17T20:49:35Z Files modified: * src/modules/rlm_python/prepaid.py * src/modules/rlm_python/radiusd.py * src/modules/rlm_python/rlm_python.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/61d471669e1998acc3066... ====== Show operator that is actually used instead of the default in rlm_python So if we remove a certain attribute, display "!* ANY" instead of "= ANY" Herwin Weststrate@2015-12-17T20:49:35Z Files modified: * src/modules/rlm_python/rlm_python.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/fd9f0065965d1d02207d2... ====== Use other functions to update list after rlm_python call Now we also support things like "!* ANY" to remove items. Herwin Weststrate@2015-12-17T20:49:28Z Files modified: * src/modules/rlm_python/rlm_python.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d9c58972ad6b50486d5ef... ====== Show list name in debug messages in rlm_python The module has the possibility to update the reply and the control list. It is nice to know what list is updated or generates errors. The name of the parameter is based on the parameter with the same use in `rlm_perl`. Herwin Weststrate@2015-12-17T19:04:07Z Files modified: * src/modules/rlm_python/rlm_python.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/3b8e4c299ab38c7cd25a3... ====== -- This commit summary was generated @2015-12-21T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).
participants (1)
-
announceļ¼ freeradius.org