1.1.2 is broken if you have closefrom()

Frank Cusack fcusack at fcusack.com
Fri Jun 16 00:01:58 CEST 2006

On June 15, 2006 12:42:34 PM +0200 Nicolas Baradakis <nbk at sitadelle.com> wrote:
> Frank Cusack wrote:
>> On June 9, 2006 1:56:16 PM +0200 Nicolas Baradakis <nbk at sitadelle.com> wrote:
>> > I also note the autotools versions have to be compatible: libtool 1.4
>> > comes with autoconf 2.13, and libtool 1.5 comes with autoconf 2.50.
>> > Upgrade one but not the other may lead to unpredictable results.
>> Well, even 1.1 as-is actually requires autoconf-2.50.  I was going to put
>> add that to configure.in as part of the patch.
> I don't understand: the current branch 1.1 with libtool 1.4 has always
> used autoconf 2.13.

My mistake;  autoconf-2.13 merely generates a warning about AC_TRY_RUN
with branch 1.1.  It was only after I updated libtool that it required

BTW, creating "test" branches to try stuff out, then merging them back,
is trivial with p4.  There wouldn't be any question about submitting.
(And this is where p4 beats svn also, so I've read.)


More information about the Freeradius-Devel mailing list