Debian Dependencies - CVS Head

Nicolas Baradakis nbk at
Mon Sep 3 14:30:08 CEST 2007

Humberto Diogenes wrote:

> On 02/09/2007, at 10:35, Nicolas Baradakis wrote:
> > >   It's OK for me if you decided to break compatibility with Debian
> > > Sarge, but I expect FreeRadius 2.0 to be compatible with at least
> > > Ubuntu Server LTS (Dapper).
> >
> > Sorry, but it isn't as simple as putting a few numbers after the
> > packages names in the dependencies.
>   Yes, I know that. I just thought it wouldn't be so hard because
> pre1 worked even on Sarge.

The scripts have been updated in pre2 and are now a lot better and
also easier to maintain. The downside is that newer utilities are

After reexamination the only thing I could change is downgrading
dpkg-dev (>= 1.13.25) to 1.13.19 so the package may build on edgy or
knoppix. As Stephen said, 1.13.19 is the minimum required version for
the variable ${source:Version}. Although I couldn't test it, the
other changes in dpkg-dev should not affect the freeradius package.

> > My goal is to provide the best possible package for the Debian
> > users. I'm not inclined to remove the new features for Ubuntu's
> > long-term support.
>   Well, if that's how it'll be done, I suggest it should be clearly
> stated in the docs: "Debian package creation will only work on Etch",
> or something like that.

No because it is just not true. The pre2 will work on all the variants
of Debian that are up-to-date. The problem here is not really FreeRADIUS,
it's because Ubuntu is providing to you a distribution with obsolete

Nicolas Baradakis

More information about the Freeradius-Devel mailing list