status server

Gabriel Blanchard gabriel at
Wed Jan 21 22:27:41 CET 2009

Man I've been bugging you guys all day... Another issue came up when I  
tried to enable the status server. I used the default settings  
provided and this is what I get.

/usr/local/etc/raddb/sites-enabled/status[20]: Failed to find module  
/usr/local/etc/raddb/sites-enabled/status[19]: Errors parsing  
authorize section.

 From what I understand "ok" isn't even supposed to be processed by  

I found another thread regarding this pasted below...

 >> /opt/radius/etc/raddb/sites-enabled/status[63]: Failed to find  
 >> Wed Nov 26 15:53:18 2008 : Error:
 >> /opt/radius/etc/raddb/sites-enabled/status[61]: Errors parsing  
 >> section.
 >> Wed Nov 26 15:53:18 2008 : Debug:  }
 >> Wed Nov 26 15:53:18 2008 : Debug: }
 >> Wed Nov 26 15:53:18 2008 : Error: Errors initializing modules
 >> The same config works fine with REL3 and 32 bit.
 >> Any ideas what could be wrong ?
 >  Nope.  I'll see if I have access to a 64-bit system.
 >  Alan DeKok.

I'm using FreeBSD amd64 so I figured that I'm also affected. After  
digging for an hour in the source code I pretty much gave up, but I  
did find a work-around by declaring

         always okhack {
                 rcode = ok

and then replacing the "ok"s with okhack in the status server. That  
seems to have fixed it.


More information about the Freeradius-Devel mailing list