sqlcounter return noop for your request!

Hamid Reza Hasani hr.hasani at gmail.com
Wed Sep 2 09:25:12 CEST 2009

I installed freeradius-1.7.1 on fedora 8 and I used pptp as nas.
Everything is worked good until we decided to define daily counter for our
radius server.
We defined a sqlcounter for it, but when a user log into server, the session
timeout is worked nice, but no one is care about daily counter.
I see these lines when I run it with -X:

rlm_sqlcounter: Could not find Check item value pair
modcall[authorize]: mudule "dailycounter" returns noop for request 0

I trace the source and I found that in rlm_sqlcounter.c we have null value
for request->config_items so pairfind can't work.
My question is where request->config_items is filled? or whereis my problem?
how I can solve it?

thnaks for you help
Hamid Reza Hasani

Ya Ali
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-devel/attachments/20090902/32c0aa83/attachment.html>

More information about the Freeradius-Devel mailing list