[libfreeradius-client] Send request to non-standard ports

Kevin Lemonnier kevin.lemonnier at iperlab.net
Wed Oct 5 12:26:42 CEST 2011

Okay, I tried some things.

I tried to put as auth server in radiusclient.conf
Without the port, the standard 1812 is used and all works fine. With the
:11812 I have this error

Oct  5 12:19:09 trixbox1 [FREERADIUS-CLIENT][3991]: rc_ip_hostname:
couldn't look up host by addr: C0A8166B
Oct  5 12:19:09 trixbox1 [FREERADIUS-CLIENT][3991]: rc_send_server: no
reply from RADIUS server unknown:11812

No idea why.
I also tried to modify the authserver->port[0] directly in the
rc_handle, and I have exactly the same error.

With both method, the exactly same result, these erros in
/var/log/messages and the radius running on 11812 just drop the request,
with an "unknown client" in the logs.

I'm using the freeradius 1.1.4 because the 1.1.5 and 1.1.6 always
segfaults with me. I searched on google, someone posted a patch for that
segfault but after patching I have a different segfault ..
The 1.1.4 version is the more recent working version when I searched a
RADIUS librairy.
May that be the problem ? 1.1.4 do not handle the non standard port
correctly ?


More information about the Freeradius-Devel mailing list