Need help on installing FR with postgresql.

artaxerxe mapandrei at
Thu Feb 2 10:41:36 CET 2012


I installed FR in my CentOS 6.2 from source. Doing a radtest on it, works
good with files authentication. I try to change the authentication to sql
mode, and I get the following error when I start FR:

Thu Feb  2 11:30:36 2012 : Error: Could not link driver rlm_sql_postgresql: cannot open shared object file: No such file or
Thu Feb  2 11:30:36 2012 : Error: Make sure it (and all its dependent
libraries!) are in the search path of your system's ld.
Thu Feb  2 11:30:36 2012 : Error:
/netnfork/radius-server//etc/raddb/sql.conf[22]: Instantiation failed for
module "sql"
Thu Feb  2 11:30:36 2012 : Error:
/netnfork/radius-server//etc/raddb/sites-enabled/default[177]: Failed to
load module "sql".
Thu Feb  2 11:30:36 2012 : Error:
/netnfork/radius-server//etc/raddb/sites-enabled/default[69]: Errors parsing
authorize section.

When I installed the FR, I put a --prefix=/my/path to the ./configure
command. The resulted warnings, that are related to my problem, are: 

configure: WARNING: silently not building rlm_sql_postgresql.
configure: WARNING: FAILURE: rlm_sql_postgresql requires:  libpq-fe.h libpq.

I want to use FR with postgresql, and I have postgresql installed on my
system, and also the FR database is already well done. (I know that because
I have a FR installation under the default location. I installed it via yum,
and it works good). So, can anybody explain me how to resolve my issue? I
tried to install libpq-fe.h, but I didn't find it. 
I also tried to run the following:
# ./configure --prefix=/my/path/
--with-postgresql-include-dir=/usr/pgsql-9.1/lib/ | grep -i WARNING
but with the same WARNING.

Can anybody help me on this? 


View this message in context:
Sent from the FreeRadius - Dev mailing list archive at

More information about the Freeradius-Devel mailing list