v2.1.x branch renamed to v2.x.x

Arran Cudbard-Bell a.cudbardb at freeradius.org
Mon Oct 29 11:25:36 CET 2012

On 28 Oct 2012, at 16:37, Alan DeKok <aland at DEPLOYINGRADIUS.COM> wrote:

> Arran Cudbard-Bell wrote:
>> Yeah something extremely weird happened when I tried to merge some guys changes back in. I've now corrected it.
>  Uh... "git reset --hard HEAD^^^^", followed by "git pull", followed by
> another attempt at merging.

Something really bizarre happened when I tried to cherrypick directly from a tracking branch from the guy who submitted the perl tagged attribute pull request.

It didn't include the correct author id, and when I did a rebase -i HEAD~2 e, git commit --ammend --author <blah>, rebase --continue it didn't do the rebase correctly and set the original commit as the HEAD ref which was why the repo was reset to the state it was nine months in the past.

I think this was a bug in tower, so i'll just use the git CLI to do this sort of thing in future.

>> You might have to dig out the last few commits and git pull to get back to the correct HEAD ref.
>  I see a number of commits I made were re-done.

Yes i'll claim responsibility on that one, sorry.


More information about the Freeradius-Devel mailing list