Release of Version 2.2.1

Stefan Winter stefan.winter at
Mon Jun 10 13:31:59 CEST 2013


I know 3.0.0-beta1 is the cool new hot topic to work with, but still, I
am dealing with a 2.x version which needs to work with SSHA1 and systemd.

I've just tried a fresh github 2.x.x branch to see where things are
regarding 2.2.1 and the stability I need. :-)

I can confirm that the SSHA1 double-normalize bug has gone away for me;
I keep authenticating some 10.000 users with SSHA1 now, so far without
any issues.

When I SIGTERM the server - as is required to work with systemd - I
still see that while freeing mainconfig, there is a SEGFAULT. It looks
like it's still at the same spot as reported earlier: if one has an sql
module instance and a custom SQL query for that instance in unlang, then
the server tries to "do something" with the custom query as it walks
through the vservers; possibly trying to tear down the corresponding sql
instance twice or so(?).

See my original message below - and if some more detail is needed, I can
work on debugging things in the coming days as it seems to be a calm
week :-)


>>   Well.. I'd like to know why it's crashing.  That really needs to be fixed.
> Ok, I've invested some more time into this: the config I run is rather
> complex, many vservers, many clients - so I deleted all parts one after
> another to see when the crashes occur and when not. I got a useful
> result, I believe:
> there is one line in one virtual server which leads to the segfault -
> comment it, stuff works, activate it, it breaks.
> I now have only two localost clients (one v4, one v6), one virtual
> server, and have taken out most modules and unlang to isolate the
> problem as good as possible.
> The result is the attached virtual server definition; the line which
> produces the segfault is the "if" inside post-auth. Note that
> sql-webmailsso is an existing module, and it's instantiated just fine,
> and used with its normal SQL commands in authorize (except that the SQL
> server doesn't allow connections from this test server; so the handles
> are not up after starting). The custom INSERT in post-auth seems to be
> the "guilty" part of my config, even if it's never executed; the
> segfaults occur when terminating the server right after it started.

Ingenieur de Recherche
Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et
de la Recherche
6, rue Richard Coudenhove-Kalergi
L-1359 Luxembourg

Tel: +352 424409 1
Fax: +352 422473

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 263 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the Freeradius-Devel mailing list