Commit report for master branch

The git bot announce at freeradius.org
Wed Jan 22 00:00:02 CET 2014


New activity for FreeRADIUS (the high performance and highly configurable RADIUS server)

======
Arg no longer used

Arran Cudbard-Bell at 2014-01-21T23:57:54Z
Files modified:
	* src/modules/rlm_rest/rest.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/f7e3080c7f6b2ebfd91917ad33b21ba81736d37d
====== 
Update ChangeLog

Arran Cudbard-Bell at 2014-01-21T23:50:49Z
Files modified:
	* doc/ChangeLog

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/70b623ce62d3b6585f322db9f3703b1275a8a84b
====== 
Doxygen

Arran Cudbard-Bell at 2014-01-21T23:41:09Z
Files modified:
	* src/main/log.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/ebdb81ef298c6b24168c1ae600129b4be55b9078
====== 
Fixup format strings

Arran Cudbard-Bell at 2014-01-21T23:37:34Z
Files modified:
	* src/main/process.c
	* src/modules/rlm_eap/eap.c
	* src/modules/rlm_eap/rlm_eap.c
	* src/modules/rlm_ldap/ldap.c
	* src/modules/rlm_mschap/opendir.c
	* src/modules/rlm_mschap/rlm_mschap.c
	* src/modules/rlm_rest/rest.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/002045e46c57c539f2b80759e20b890803160bcc
====== 
Fix operation of fr_strerror()

A while back a flag was added to fr_strerror() to stop the same error message being output multiple times (and leading to confusing debug output).

Unfortunately the macro for RERROR() and pals, inadvertently called fr_strerror() multiple times as ## __VA_ARGS__ was passed both to module_failure_msg() and radlog_request(), with the arguments to the macro being evaluated once per call.

The solution is to switch the logging functions to use va_list instead of the ellipses, add a helper to convert ## __VA_ARGS__ into va_list, and then use va_copy to create a copy of the arguments for the radlog_request() call.

As a side effect, it appears to of enabled printf format validation for more macros, so the next commit will be to fix all the places where that was previously unreported...

Arran Cudbard-Bell at 2014-01-21T23:37:33Z
Files modified:
	* src/include/log.h
	* src/include/radiusd.h
	* src/main/log.c
	* src/main/modcall.c
	* src/main/process.c
	* src/main/unittest.c
	* src/main/util.c
	* src/main/valuepair.c
	* src/main/xlat.c
	* src/modules/proto_bfd/bfd.c
	* src/modules/rlm_eap/radeapclient.c
	* src/modules/rlm_sqlhpwippool/rlm_sqlhpwippool.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/3b5642d06eb8526815ecd0ef1d8cf07201d9014d
====== 
Formatting and extra error messages

Arran Cudbard-Bell at 2014-01-21T23:37:33Z
Files modified:
	* src/lib/valuepair.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/cf4533443893355eff57f243ee4562f768bcf4ae
====== 
Split paircmp_value from paircmp_op. paircmp_value is trinary (and so can be used as cmp function in btree) paircmp_op is just binary.

Arran Cudbard-Bell at 2014-01-21T23:37:33Z
Files modified:
	* src/include/libradius.h
	* src/lib/valuepair.c
	* src/modules/rlm_expr/paircmp.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/49e5385845758a56378b787c566b959c58dc25fa
====== 
Unsigned comes after "int"

Alan T. DeKok at 2014-01-21T20:41:17Z
Files modified:
	* raddb/mods-config/sql/main/mysql/schema.sql

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/d0759a6fec9abafdefadc7a0a41fc116d17d8bb5
====== 
reconnect can be called with an unused connection handle.  Fixes #507

Alan T. DeKok at 2014-01-21T20:40:04Z
Files modified:
	* src/main/connection.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/6e68c3ef6d1fbd355ca75870788c52127effc380
====== 
Add comparisons for SIGNED and ETHERNET types

Arran Cudbard-Bell at 2014-01-21T13:52:36Z
Files modified:
	* src/lib/valuepair.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/8de2a7079752a4c23d251f47ae610e8efa38596b
====== 
Do NOT just return 0 silently if we don't support the type in paircmp, that's a great way to mess up any trees which use the function

Arran Cudbard-Bell at 2014-01-21T13:51:55Z
Files modified:
	* src/lib/valuepair.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/3f53f5b967e26f25209207682a2c877a4a8c4ebf
====== 
Correct comments

Arran Cudbard-Bell at 2014-01-21T13:38:30Z
Files modified:
	* src/main/radsniff.c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/96fb26d15b09f6de555432b36f6e8cc05bb07128
====== 
Extend the H3C dictionary based on public manuals

Try to extend the H3C dictionary based on what is scattered on
their pages. At least most of it is found quite consistently in
the product-specific "Security Configuration Guides".

This compilation/crosschecking is based H3C documentation for
listed devices:
- H3C S12500 and S6800 Switches
- H3C WA WLAN Access Points
- H3C MSR Routers

Remarks:
Does not stick with H3C's use of of underline in attribute naming.

Mathieu Simon (via Arran Cudbard-Bell)@2014-01-21T10:04:30Z
Files modified:
	* share/dictionary.h3c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/803477f565678f56bac8739aab0b11e0fdf0ff13
====== 
Revisit H3C Exec-Privilege

Try to match H3C terminology as close as to their documentation.

- The Attribute name seems to not exactly match documentation,
  found consistently user i.e. in:
  - H3C S12500: Configurations Guides
  - H3C WA Series: Security Configuration Guide

- Rename privilege levels to match H3C's documentation
  (previously likely more 3Com-ish). The levels naming
  are being used consistently mentioned throughout:
  - H3C SecPath F1000-E: Operational Manual
  - H3C S5500-SI: Operation Manual

Mathieu Simon (via Arran Cudbard-Bell)@2014-01-21T10:04:30Z
Files modified:
	* share/dictionary.h3c

Commit diff:
https://github.com/FreeRADIUS/freeradius-server/commit/3046419a3a40d0146cea18083c496703b965d8c4
====== 
-- 
This commit summary was generated @2014-01-22T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).


More information about the Freeradius-Devel mailing list