[4.0.x] build fails (module imap) with libcurl 7.29.0

Chaigneau, Nicolas nicolas.chaigneau at capgemini.com
Sun Jun 28 19:20:10 CEST 2020

It's perfectly fine to require a recent version of libcurl.

Just a minor inconsistency remains in the configure output... the minimum version shown in the WARNING is incorrect (should be 7.45.0, not 7.19.2):

checking for the version of libcurl... 7.29.0
checking for libcurl >= version 7.45.0... no
configure: WARNING: silently not building libfreeradius-curl.
configure: WARNING: FAILURE: libfreeradius-curl requires:  libcurl >= 7.19.2.
configure: creating ./config.status


This message contains information that may be privileged or confidential and is the property of the Capgemini Group. It is intended only for the person to whom it is addressed. If you are not the intended recipient, you are not authorized to read, print, retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message.

More information about the Freeradius-Devel mailing list