Debian 802.1x LDAP

Cian Phillips cian at
Tue Aug 16 08:40:32 CEST 2005


I'm trying to get a Debian (stable) box set up to authenticate users  
for our Cisco Wireless Control Software via LDAP. I have tried the  
Debian package and can get LDAP running easily. When I try to get the  
eap/tls stuff working it gives me an error about missing libraries.

rlm_eap: Failed to link EAP-Type/tls: cannot open  
shared object file: No such file or directory

I have googled this and found some messages that suggest compiling  
from source and using the --shared-disabled flag at compile time but  
I've tried building from source and can't even get LDAP working..  
each time I un-comment the ldap line from the radiusd.conf file and  
try to start using radiusd -x I get a segfault.

Ideally I would like to stick with Debian as that is what my other  
production servers are but would be willing to use something else if  
it makes easier work of this process.

If anyone has gotten Debian + 802.1x + LDAP working or even just  
802.1x + LDAP I could really use some pointers if even just to tell  
me it is or isn't possible.

Thanks in advance.

Cian Phillips

Cian Phillips
Director Network & Systems
California College of the Arts
Phone: (510) 594-3745
Cell: (510) 719-0091
Fax: (510) 594-3758
email: cian at

More information about the Freeradius-Users mailing list