Debian 802.1x LDAP

Kris Benson kbenson at
Tue Aug 16 21:51:04 CEST 2005

FreeRadius users mailing list <freeradius-users at> on
August 15, 2005 at 23:40 -0800 wrote:
>rlm_eap: Failed to link EAP-Type/tls: cannot open  
>shared object file: No such file or directory
>I have googled this and found some messages that suggest compiling  
>from source and using the --shared-disabled flag at compile time but  
>I've tried building from source and can't even get LDAP working..  
>each time I un-comment the ldap line from the radiusd.conf file and  
>try to start using radiusd -x I get a segfault.

Hi Cian,

Make sure you have done this:
apt-get install libssl-dev
apt-get install libldap2
apt-get install libldap2-dev
apt-get install libmysqlclient14
apt-get install libmysqlclient14-dev
apt-get install slapd
apt-get install ldap-utils
apt-get install db4.2-util

after those packages are all installed, try compiling again.  If that
doesn't work, let me know and I can help you further -- this is where I
solved my problem. :-)

Kris Benson, CCP, I.S.P.
Technical Analyst, District Projects
School District #57 (Prince George)

More information about the Freeradius-Users mailing list