FreeRADIUS 1.0.4 has been released.

Alan DeKok aland at
Sat Jun 18 03:09:31 CEST 2005

"Stephen D. Bechard" <steve at> wrote:
> I am still having diffuculty building the freeradius on all
> of my FreeBSD Servers with the ports collection.


> I know there was a bug in the older versions with shared libraries,
> but I was hoping this version fixed it. Any insight would be greatly
> appreciated...

  I don't recall specific problems with shared libraries.  Can you be
more specific?

> Here are the errors I get when trying to build the port:
> In file included from rlm_attr_rewrite.c:31:
> /usr/include/regex.h:46: syntax error before `regoff_t'

  That has nothing to do with shared libraries.

  It looks like the regular expression header files on your system are
broken.  'regoff_t' is defined in regex.h on every other system.

  If you're not going to use rlm_attr_rewrite, just delete the

  I would have hoped that the FreeBSD ports maintainer verified that
the port worked before committing it to FreeBSD.  If so, ask the port
maintainer why it doesn't work on your system.  I don't run FreeBSD,
so I can't help you.

  Alan DeKok.

More information about the Freeradius-Users mailing list