sql segmentaiton fault

YvesDM ydmlog at gmail.com
Wed Aug 16 15:30:57 CEST 2006

On 8/16/06, Nicolas Baradakis <nbk at sitadelle.com> wrote:
> YvesDM wrote:
> > Created my own debs of freeradius 1.0.5
> Please upgrade to 1.1.2.

I know, but the radius I'm running now (FR 1.0.5, SQL authentication,
time&volume accounting) was originally setup by somebody else.
It's working fine, but I wanted to know how everything was set up without
trashing the existing server (it's in use).
I had a spare server and decided to give it a go.
I choose to install 1.0.5 on the testradius too because then it was possible
for me to compare the config files with the existing server and see the
changes. As soon as I got everything working on my 1.0.5 testradius, I will
definately try to reproduce it again with the newest version.

> Everything works, but when i try to use mysql i get a segmentation fault
> > running radiusd -X
> See http://freeradius.org/radiusd/doc/bugs

This problem is solved now.(it took 4 days for my post to appear here,
I tried to fire it up with the config files from the existing radius and got
the segm. fault.
When I used the standard config it was running fine. So far, I got radius &
sql authentication working.
Still got to take a look to install dialup admin and the volume accounting
part, but I ran a bit out of time this week :-)
Maybe tomorrow I can work on it again.

> I used the rules file in the debian dir of the tar.gz, but added
> > --with-experimental modules as a configure option in it cause i need the
> > sqlcounter.
> sqlcounter is in the stable modules list in versions >= 1.1.0.

See above :-)
One question, on the existing radius I got  a file perl.conf in
I don't have this on my testradius and I guess I will need it.
I also have FR complaining about missing modules when I use the exisiting
server 's configfile.
Missing modules are for example "downloadlimit" When i take a look at
radiusd.conf from the existing server,
it's in the Authorize section right above the authentication section.

        #  The ldap module will set Auth-Type to LDAP if it has not
        #  already been set
#       ldap

        #  Enforce daily limits on time spent logged in.
#       daily

        # Use the checkval module
#       checkval

#  Authentication.

I guess I missed something and hope someone can help me out here.

Many tnx.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20060816/b6ebcb25/attachment.html>

More information about the Freeradius-Users mailing list