Ntlm_auth Help

King, Michael MKing at bridgew.edu
Thu Aug 24 22:24:02 CEST 2006

I'm building a new radius server.  I'm copying an existing one.

I'm getting the following error from freeRADIUS when I run it -x
(FreeRADIUS 1.1.3)

Exec-Program: /usr/bin/ntlm_auth --request-nt-key --username=mking
--challenge=46b51a98d607a3a9 --nt-response=
hex decode of  failed! (only got 0 bytes)

Of course, if I run it via the command line, it works flawlessly.
rad2:/etc/freeradius# ntlm_auth --username=mking
NT_STATUS_OK: Success (0x0)

I've copied the ntlm_auth line from my working radius server (which is
on 1.0.1, hence the reason I'm upgrading)

ntlm_auth = "/usr/bin/ntlm_auth --request-nt-key
--username=%{mschap:User-Name} --challenge=%{mschap:Challenge}

I'm at a loss why I would get 0 bytes.....

I've even 
chgrp freerad /var/run/samba/winbindd_privileged
chmod g+rx /var/run/samba/winbindd_privileged
Just to be sure (Even thought I didn't have to do that on my old radius


More information about the Freeradius-Users mailing list