freeradius 1.1.0 on mac os x server 10.4.5 not working

John Bass john_bass at
Sat Feb 18 01:22:13 CET 2006

Hi All,

I'm attempting to run freeradius 1.1.0 on mac os x 10.4.5 without  
much luck. I searched the web and found that I'm not alone. Here's an  

Here is output from an install using darwin ports then radiusd in  
debug mode...

miles:/opt/local/bin root# ./port install freeradius
--->  Fetching freeradius
--->  Attempting to fetch freeradius-1.1.0.tar.gz from ftp://
--->  Verifying checksum(s) for freeradius
--->  Extracting freeradius
--->  Configuring freeradius
--->  Building freeradius with target all
--->  Staging freeradius into destroot
--->  Packaging tgz archive for freeradius 1.1.0_0
--->  Installing freeradius 1.1.0_0
--->  Activating freeradius 1.1.0_0
--->  Cleaning freeradius
miles:/opt/local/bin root# cd /opt/local/
miles:/opt/local root# ls
bin     etc     include lib     libexec man     sbin    share   var
miles:/opt/local root# cd bin
miles:/opt/local/bin root# ls
daemondo        radclient       radrelay        radwho           
port            radeapclient    radsqlrelay     radzap           
portindex       radlast         radtest         rlm_dbm_cat
miles:/opt/local/bin root# cd ..
miles:/opt/local root# cd sbin/
miles:/opt/local/sbin root# ls
.turd_DarwinPorts       checkrad                radwatch
check-radiusd-config    radiusd                 rc.radiusd
miles:/opt/local/sbin root# ./radiusd -X
Starting - reading configuration files ...
reread_config:  reading radiusd.conf
Config:   including file: /opt/local/etc/raddb/proxy.conf
Config:   including file: /opt/local/etc/raddb/clients.conf
Config:   including file: /opt/local/etc/raddb/snmp.conf
Config:   including file: /opt/local/etc/raddb/eap.conf
Config:   including file: /opt/local/etc/raddb/sql.conf
main: prefix = "/opt/local"
main: localstatedir = "/opt/local/var"
main: logdir = "/opt/local/var/log/radius"
main: libdir = "/opt/local/lib"
main: radacctdir = "/opt/local/var/log/radius/radacct"
main: hostname_lookups = no
main: max_request_time = 30
main: cleanup_delay = 5
main: max_requests = 1024
main: delete_blocked_requests = 0
main: port = 0
main: allow_core_dumps = no
main: log_stripped_names = no
main: log_file = "/opt/local/var/log/radius/radius.log"
main: log_auth = no
main: log_auth_badpass = no
main: log_auth_goodpass = no
main: pidfile = "/opt/local/var/run/radiusd/"
main: user = "(null)"
main: group = "(null)"
main: usercollide = no
main: lower_user = "no"
main: lower_pass = "no"
main: nospace_user = "no"
main: nospace_pass = "no"
main: checkrad = "/opt/local/sbin/checkrad"
main: proxy_requests = yes
proxy: retry_delay = 5
proxy: retry_count = 3
proxy: synchronous = no
proxy: default_fallback = yes
proxy: dead_time = 120
proxy: post_proxy_authorize = no
proxy: wake_all_if_all_dead = no
security: max_attributes = 200
security: reject_delay = 1
security: status_server = no
main: debug_level = 0
read_config_files:  reading dictionary
read_config_files:  reading naslist
Using deprecated naslist file.  Support for this will go away soon.
read_config_files:  reading clients
read_config_files:  reading realms
radiusd:  entering modules setup
Module: Library search path is /opt/local/lib
radiusd.conf[1541] Failed to link to module 'rlm_exec': dlopen(/opt/ 
local/lib/, 9): Symbol not found: _debug_flag    
Referenced from: /opt/local/lib/   Expected in: flat  
miles:/opt/local/sbin root#

I've tried compiling from the source as is and with the shared  
library option off. In all cases I get the same result.

Any ideas?

John Bass
john_bass at
(919) 515-0154

Never ask a barber if you need a haircut.

More information about the Freeradius-Users mailing list