FreeRadius and MySQL boot problem

Diniz Da Rocha dinizd at
Mon Feb 27 06:56:46 CET 2006


I have currently setup FreeRadius 1.0.4 with ldap authentication and
authorization as well as mysql authorization and its all working fine. My
only problem is that when I boot the server (Fedora Core 4) and radiusd
starts up there is a rlm_sql_mysql error:

Wed Feb 15 18:38:51 2006 : Info: rlm_sql (sql): Trying to (re)connect
unconnected handle 4..
Wed Feb 15 18:38:51 2006 : Info: rlm_sql_mysql: Starting connect to MySQL
server for #4
Wed Feb 15 18:38:51 2006 : Error: rlm_sql_mysql: Couldn't connect socket to
MySQL server radius_client at myip:radius
Wed Feb 15 18:38:51 2006 : Error: rlm_sql_mysql: Mysql error 'Can't connect
to MySQL server on 'myip' (13)'
Wed Feb 15 18:38:51 2006 : Error: rlm_sql (sql): Failed to connect DB handle

The MySQL server is on another server with ip "myip" I initially thought it
was a firewall block but even with no firewall I get this error. But once
the server has started and I run "service radiusd restart" from a terminal
the connect to the MySQL server works fine and has no problems. I even tried
running the service from rc.local but it still fails did anyone have this
problem??? is anyone running the MySQL server on another machine???? Is
there a fix for this???


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list