Error: rlm_sql_mysql: MYSQL Error

jayesh jayesh at
Fri Jul 7 16:50:36 CEST 2006

Hi all,
I am using freeradius 1.1.0. The backend is mysql 5.0.22 which is
located on a different server on the same network.
My configuration is as follows:
I am doing some stress testing to benchmark my infrastructure.
I use SIPp for the same. The SIPp sends the calls to cisco gateway, the
cisco gateway sends the authentication request to freeradius server. The
radius server queries the mysql database and once the authentication is
successful and the call is completed; the accounting request is also
passed to the radius server by cisco which in turn is sent to the mysql
Now I kept the SIPp at rate of 45 calls per second, but after say 10 to
15 minutes the radius server dies. This is the message I could see in
the log:
rlm_sql (sql): There are no DB handles to use! skipped 0, tried to
connect 0
Error: rlm_sql_mysql: MYSQL Error: Cannot get result
Fri Jul  7 14:18:46 2006 : Error: rlm_sql_mysql: MYSQL Error:
Fri Jul  7 14:18:46 2006 : Error: rlm_sql_mysql: MYSQL Error: No Fields
Fri Jul  7 14:18:46 2006 : Error: rlm_sql_mysql: MYSQL error:
Fri Jul  7 14:18:46 2006 : Info: rlm_sql_mysql: Starting connect to
MySQL server for #4
Fri Jul  7 14:18:46 2006 : Error: rlm_sql (sql): failed after
I tried googling the archive but could not get a proper solution. One
more thing; I had configured rlm_mysql using the following command:
./configure --without-thread.
Could this be a cause of some problem, I did this as the radius was not
finding mysql libraries.
Can someone please help on this.
Thanks in advance.
Jayesh Nambiar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list