RPM build problems on RedHat AS4

B Thompson bt4 at york.ac.uk
Tue Jun 20 12:49:57 CEST 2006


Following previous posts on this mailing list I patched my freeradius.spec as
shown at the end of this email. I ran rpmbuild -bb and got the lib_eap
packaging problems and during the build many messages like this :-

(cd /usr/src/redhat/BUILD/freeradius-1.1.2/src/modules/rlm_eap; /bin/sh /usr/src/redhat/BUILD/freeradius-1.1.2/libtool --mode=relink gcc -release 1.1.2 -modul\e -export-dynamic -o rlm_eap.la -rpath /usr/lib rlm_eap.lo eap.lo mem.lo state.lo rlm_eap.c eap.c mem.c state.c /usr/src/redhat/BUILD/freeradius-1.1.2/src/lib\/libradius.la libeap/libeap.la -lltdl -lnsl -lresolv -lpthread)
gcc -shared  rlm_eap.lo eap.lo mem.lo state.lo  -L/usr/src/redhat/BUILD/freeradius-1.1.2/src/lib/.libs -L/usr/lib -lradius -leap -lltdl -lnsl -lresolv -lpthre\ad    -Wl,-soname -Wl,rlm_eap-1.1.2.so -o .libs/rlm_eap-1.1.2.so
/usr/bin/ld: cannot find -leap
collect2: ld returned 1 exit status
libtool: install: error: relink `rlm_eap.la' with the above command before installing it
libtool: install: warning: remember to run `libtool --finish /usr/lib'
gmake[6]: Leaving directory `/usr/src/redhat/BUILD/freeradius-1.1.2/src/modules/rlm_eap'

I then ran rpmbuild again and although I don't remember changing anything it worked fine
and built me an rpm. However when I came to install, I still have the following
dependency problem :-

error: Failed dependencies:
        /usr/local/bin/perl is needed by freeradius-1.1.2-0.i386

The output of "whereis perl" :-

perl: /usr/bin/perl /usr/local/bin/perl /usr/share/man/man1/perl.1.gz

# ls -l /usr/local/bin/perl
lrwxrwxrwx  1 root root 13 Jun 21  2004 /usr/local/bin/perl -> /usr/bin/perl

Could anyone suggest why I am gettting the failed dependendcy?


Ben Thompson

Here is the patch :-

--- freeradius.spec.orig        2006-05-21 18:32:53.000000000 +0100
+++ freeradius.spec     2006-06-20 11:40:59.000000000 +0100
@@ -38,6 +38,9 @@

+sed -i "s at doc/freeradius at doc/freeradius-%{version}@" doc/Makefile doc/examples/Makefile doc/rfc/Makefile
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT

@@ -111,6 +114,18 @@
 %attr(0700,radiusd,radiusd) %dir /var/log/radius/radacct
 %attr(0700,radiusd,radiusd) %dir /var/run/radiusd

+%doc doc/Acct-Type doc/Autz-Type doc/CYGWIN doc/ChangeLog doc/DIFFS doc/MACOSX
+%doc doc/OS2 doc/Post-Auth-Type doc/RADIUS-LDAP-eDirectory doc/RADIUS-SQL.schema
+%doc doc/README doc/Session-Type doc/Simultaneous-Use doc/aaa.txt doc/ascend
+%doc doc/bay doc/bugs doc/cisco doc/coding-methods.txt doc/configurable_failover
+%doc doc/duplicate-users doc/ldap_howto.txt doc/load-balance.txt doc/misc-nas
+%doc doc/module_interface doc/mssql doc/performance-testing doc/processing_users_file
+%doc doc/proxy doc/radrelay doc/release-method.txt doc/rfc/
+%doc doc/rlm* doc/supervise-radiusd.txt
+%doc doc/tuning_guide doc/variables.txt todo/ COPYRIGHT INSTALL
 * Thu Dec 15 2004 Alan DeKok
 - update for 1.1.0

More information about the Freeradius-Users mailing list