build rpm packages on centOS

Michael Messner michael.messner_edv at
Tue Nov 14 12:40:46 CET 2006

Patric sagte:
> Michael Messner wrote:
>> hey @all,
>> cp: will not overwrite just-created
>> `/var/tmp/freeradius-root/usr/share/doc/freeradius-1.1.3/README' with
>> error: Bad exit status from /var/tmp/rpm-tmp.73012 (%doc)
>> RPM build errors:
>>     Bad exit status from /var/tmp/rpm-tmp.73012 (%doc)
>> any ideas?
> Have you tried compiling the source?

that works!

> What you will probably find is that make will fail, and will give you a
> more detailed description on where the compile is _actually_ failing.
> My suggestion is to try compile from source. I had a similar problem
> trying to build a php-java-bridge rpm on CentOS a while back.
> Turns out the gcc compiler was getting itself in a knot, and incorrectly
>  reporting duplicate methods. My solution was to use make with the "-i"
> switch - ignore errors.

if I add the -i in the spec file there is no change ... same error!

thanks mIke

More information about the Freeradius-Users mailing list