double free or corruption errors with 2.0.0-pre0

matthew zeier mrz at
Sun Apr 8 02:01:24 CEST 2007

Alan DeKok wrote:
> matthew zeier wrote:
>> Doesn't dump core so all I got was:
>   As you posted before.
>   Let me clear: I cannot reproduce this problem here.  No one else has
> seen the same problem.

I find that hard to believe since google found a number of hits 
( is a good example) to the same error I was seeing 
with FreeRADIUS without any solutions that wfm (I upgraded perl and grabbed 
from cvs, as suggested a number of times)

>   You now have a choice.  You can do whatever it takes to help solve the
> problem, including reading documentation for how glibc's double free
> works, and how to get more information out of it.  You can offer to give
> people an account on your machine so that people with more experience
> than you can debug the problem for themselves.
>   Or, you can keep posting the same error message, and wondering why the
> problem hasn't been fixed.

This list has so far provided the least amount of help for any open source 
tool I've ever used.

I'm an end user, not a developer so digging into how glibc works is beyond my 
scope.  You directed me at docs/bugs and I followd that - didn't get anything 
from that other than what I posted (which, incidentally, was more that I 
posted the last time).

Since I'm running stock RHEL4, this should be easy to duplicate.  Are you 
suggesting that if Mozilla gave you a RHEL4 system, you'd be able to fix it? 
If that's what you're saying, send me your public key and I'll have a host 
online tonight.

- mz

More information about the Freeradius-Users mailing list