Server blown up after move

John Ellin john at
Thu Dec 20 01:31:58 CET 2007

Hi all,

Recently had to move free radius 1.1.7 from production server to test/backup 
server due to failed HD in RAID.

config is radius + LDAP and worked fine on the old machine but, on the new 
machine it works fine when debugging, but not at all when running as a 

Output from netstat -l shows that the server is listening on the correct ports 
on the ('listen'ed) sockets when running as a daemon:

[root at nw raddb]# netstat -l | grep radius
udp        0      0 *:*
udp        0      0 *:*
udp        0      0 nw.4cco:radius-acct     *:*
udp        0      0 nw.4cco:radius-acct     *:*

(doubling up is for lo and eth0)

(also tried 'bind_address = *')

however output from radtest is:

Re-sending Access-Request of id 218 to port 1812
        User-Name = "john"
        User-Password = "removed"
        NAS-IP-Address =
        NAS-Port = 0
radclient: no response from server for ID 218

and nothing appearing in radius.log.

Using radiusd -X:

[root at nw raddb]# radtest john removed 0 also_removed
Sending Access-Request of id 14 to port 1812
        User-Name = "john"
        User-Password = "removed"
        NAS-IP-Address =
        NAS-Port = 0
rad_recv: Access-Accept packet from host, id=14, length=20

Tried running in debug as radius:radius and still worked, so it doesn't appear 
to be a problem with config directory/file ownership.

Any suggestions would be greatly appreciated...

 Best regards,

More information about the Freeradius-Users mailing list