Freeradius-Users Digest, Vol 32, Issue 65

John Ellin john at
Thu Dec 20 20:18:43 CET 2007

On December 20, 2007 06:00, freeradius-users-request at 
> > config is radius + LDAP and worked fine on the old machine but, on the
> > new machine it works fine when debugging, but not at all when running as
> > a daemon.
>   You can run it as a daemon, *and* have extended debugging.  Just use
> radiusd -xxx.
> > Tried running in debug as radius:radius and still worked, so it doesn't
> > appear to be a problem with config directory/file ownership.
> >
> > Any suggestions would be greatly appreciated...
>   Run it as "radiusd -fxxx" from the command line, and see if it works
> then.

If I run it as -xxx from the command line it works. As soon as I drop the -x 
it stops working:

 radiusd -xxx works
 radiusd -x works
 radiusd -y doesn't work
 radiusd doesn't work

my default sys V init script has -y. I have changed it to -x and it works, but 
it is worrying that I didn't have this problem before I moved to the new 

Also, using -x makes it run in the foreground, whether or not I'm using -f. 
I'm starting to wonder if the guys at Mandriva have been messing in the code 
for their distribution...


 Best regards,

There's a fine line between being on the leading edge and being in the lunatic 
 --- Frank Armstrong

More information about the Freeradius-Users mailing list