Hibernating: Major impact on authentication!

Guilherme Franco guilhermefranco at gmail.com
Mon Feb 5 21:30:57 CET 2007


Considering that all things indicate that there might be a problem with the
DB, I did some tweaks in PostgreSQL and took off the cron.hourly job.

Gonna watch out for problems then, thanks!



Freeradius 1.1.4 is randomly losing connection to both databases and it's
causing total loss in the authentication process:

Info: rlm_sql (sql): There are no DB handles to use! skipped 0, tried to
connect 0
Info: rlm_sql (sql_postgresql): There are no DB handles to use! skipped 0,
tried to connect 0
Info: The maximum number of threads (32) are active, cannot spawn new thread
to handle request

Running either in multi or single threaded mode, that messages appeared
47.099,00 times since Jan 27! Freeradius is configured with 32 max_servers
and 32 connections to each DB. There's no starving since no accounting is
being used and the server have to handle just 3 auths per second.

Every time this happens, no one can authenticate and doing a restart in
Freeradius solves the problem. To circumvent the problem, I've added a
cron.hourly job so each hour a "service radiusd restart" is issued.

As this is random, it's hard to debug, but at the same time freeradius loses
the connection, several other applications can successfully connect/
maintain previous established connections to the databases. I've enabled all
sorts of debug in the databases trying to better understand why freeradius
is doing this, but there was no luck.

I've installed the latest CVS and the same problem appeared, please help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20070205/8382c115/attachment.html>

More information about the Freeradius-Users mailing list