Error: Ignoring request from unknown client IP:1645

Davide Molteni d.molteni at
Tue Feb 13 17:24:14 CET 2007

Ok you got it! It was a simple user permissions problem on the file
clients.conf! Shame on me...
The daemon tried to read the old confguration files clients and naslist
just because user that runs radiusd can't access the actual clients.conf
Now everything is working fine, I have to review some concepts on cisco
AAA because it won't authorize my users but just authenticate it but
this issue it's surely on cisco side.

Thanks a lot for the quick help 

Il giorno mar, 13/02/2007 alle 15.26 +0100, Alan DeKok ha scritto: 
> Davide Molteni wrote:
> >>> Error: Ignoring request from unknown client ipmycisco:1645
> >>   Did you configure the server to have that IP in "clients.conf"?
> > 
> > Sure! With the IP and the same shared key as the cisco NAS client
>   <shrug>  The server isn't finding it.
>   Are you sure the server is reading the "clients.conf" file you're editing?
> > Please notice that I would like to use this radius for simple PAP ONLY.
> > Maybe I'm doing something wrong with users file?
>   No.
> > Please tell me the right way to configure a single test user for PAP
> > only. I would like to disable unused modules (ldap,mysql...)
>   It's in the FAQ.
> > It couldn't be a problem of authentication method?
>   No.
> > I forgot an important element to tell anyone wants to help.
> > I tried to change the shared key on one side (radius) and noticed that
> > log file continue to write again the same error
> > 
> > Ignoring request from unknown client IP:1645
> > 
> > So the issue it's due to the fact that cisco client don't exchange
> > shared key with radius...
>   No.  They don't exchange shared keys.  You MUST list the Cisco's IP in
> "clients.conf".
>   It looks like you're not doing that, or you're doing it wrong, or
> you're editing a file the server isn't reading.
>   Alan DeKok.
> --
>       - The web site of the book
> - The blog

More information about the Freeradius-Users mailing list