1.1.4 stops responding to requests

Stefan Winter stefan.winter at restena.lu
Tue Feb 13 20:20:43 CET 2007


> 1.1.4 will run for a few hours and then either stop responding to
> requests or die.   There is no seg fault warning in any log file.  If I
> restart radius, it then begins answering again.  Since it is a
> production environment in which 300-500 users are connected at any given
> time, we were unable to simply turn on debugging and look for problems.
> Once we realized the problem we had to quickly revert to 1.0.5 for now
> and make our relatively few Vista users for a little longer.

Interesting... I've been seeing exactly this happening on our own system. In 
our case, I could track it down to the fact that it stopped responding 
shortly after accounting packets came in. Turning off accounting (already on 
NAS level) deterministically solved the problem for me, so I suspect the 
problem to be somewhere near there.
I never followed this trace, because accounting is optional at our site (free 
wireless) and it was our prod environment, I didn't want to mess around 
without a good reason. So accounting is just off at the moment.

> I am going to try running it in debug mode over a weekend in a
> particular subset of the school's wireless network where not many users
> would be affected by a crash and see if I can collect any more
> information.  I will do it on a system that never had any earlier
> version of freeradius installed on it, just to be safe.  In the
> meantime, any advice would be appreciated.

Is it an option to not do accounting? Or maybe queue the acct in files rather 
than a proper backend (for me, the issue happened in combination with mysql). 
I never tried if the hangs occur also when logging to a file.


Stefan Winter


Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et de 
la Recherche - Ingénieur de recherche

6, rue Richard Coudenhove-Kalergi
L-1359 Luxembourg

More information about the Freeradius-Users mailing list