1.1.4 and rlm_sql_mysql.so

Jeffrey Sewell jeffrey.sewell at gmail.com
Tue Jan 9 23:18:54 CET 2007

I'm installing freeRADIUS on a CentOS 4.0 system. When I used the RPM
on a different box it worked fine, but the RPM is out of date and I
want this new box to be more up-to-date than RPMs will allow.

1.1.4 compiles fine and works w/o MySQL (5.0). However, when I run it
with the SQL lines in radiusd.conf uncommented, I get this:

rlm_sql (sql): Could not link driver rlm_sql_mysql: rlm_sql_mysql.so:
cannot open shared object file: No such file or directory
rlm_sql (sql): Make sure it (and all its dependent libraries!) are in
the search path of your system's ld.
radiusd.conf[14]: sql: Module instantiation failed.
radiusd.conf[1844] Unknown module "sql".
radiusd.conf[1773] Failed to parse authorize section.

that library is on my other (RPM-installed) system, but is not
anywhere on the file system of the new box (including the source
dir--it isn't in the tarball).

Where is that file stored for 1.1.4? Are there other libraries that I
will need that should be with that one and are also missing?


More information about the Freeradius-Users mailing list