RADIUS will no longer start!

Kevin Bonner keb at pa.net
Wed Jan 24 17:01:01 CET 2007

On Wednesday 24 January 2007 10:02, Michelle Gates wrote:
> read_config_files:  reading clients
> /opt/freeradius/etc/raddb/radiusd.conf[751]: Missing client name
> -----
> Can anyone shed any light on this? Unfortunately for me, one of our
> developers was working on our production server but *claims* not to have
> changed anything of any consequence...
> I'm really unsure of where this is coming from! Has anyone seen this error
> before or could anyone at least point me in the right direction?

Since you have multiple people poking around on a production config, you are 
using some sort of revision control... right?  ;-)

I tried to reproduce the error locally and here is what I've done to cause the 
same error message to show up.

== clients.conf ==
client {
        secret          = testing
        shortname       = testing
        nastype         = other
== clients.conf ==

[root at noctest raddb.dial]# /usr/sbin/radiusd -X
read_config_files:  reading clients
/etc/raddb/radiusd.conf[327]: Missing client name

To fix the issue, find the broken client entry and either comment it out or 
restore it with the correct client IP.

Kevin Bonner
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20070124/0478fdf8/attachment.pgp>

More information about the Freeradius-Users mailing list