2.0.5 on Solaris with openssl 0.9.8h

Andrew Hood freeradius at andyhood.net
Sun Aug 17 12:55:05 CEST 2008

Alan DeKok wrote:
> Rafiqul Ahsan wrote:
>>Ok, I tried as follows :
> ...
>>Still "ldd /usr/local/sbin/radiusd" shows the shared object from
>   Then the issue is that the linker is linking against "libssl.so", and
> not "libssl.so.0.9.8".  This means that at run-time, /usr/sfw/lib is
> found *before* /usr/local/lib, and so it links to the other version of
> libssl.
>   The only solutions are:
>   a) change the order of directories that the run-time linker uses
>   b) delete the /usr/sfw/lib/libssl* files

I haven't tried the method I suggested earlier in this thread on
Solaris. I have done it on Linux. For reasons too complex to go into I
can not replace the default version of openssl, but I need a later
verison to build freeradius. I put that version in the same target

openssl config:
./Configure no-shared enable-zlib-dynamic \
    --prefix=/opt/freeradius --openssldir=/opt/freeradius/ssl \

freeradius configure script:

export PKG_CONFIG_PATH=/opt/freeradius/lib/pkgconfig
export CC='gcc -march=i686'
export F77='g77 -march=i686'
export CXX='g++ -march=i686'
export LDFLAGS='-Wl,-rpath -Wl,/opt/freeradius/lib'
./configure \
    --prefix=/opt/freeradius \
    --localstatedir=/var \
    --with-openssl-includes=/opt/freeradius/include \

And it works:

$ ldd /opt/freeradius/sbin/radiusd
        libfreeradius-radius-2.0.5.so =>
/opt/freeradius/lib/libfreeradius-radius-2.0.5.so (0x40016000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x4004d000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x40062000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x40072000)
        libsnmp.so.15 => /usr/local/lib/libsnmp.so.15 (0x40087000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x4012e000)
        libltdl.so.3 => /usr/lib/libltdl.so.3 (0x4015b000)
        libdl.so.2 => /lib/libdl.so.2 (0x40162000)
        libssl.so.0.9.8 => /opt/freeradius/lib/libssl.so.0.9.8 (0x40166000)
        libcrypto.so.0.9.8 => /opt/freeradius/lib/libcrypto.so.0.9.8
        libc.so.6 => /lib/libc.so.6 (0x402c6000)
        libcrypto.so.0 => /usr/lib/libcrypto.so.0 (0x403e9000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

REALITY.SYS not found: Universe halted.

More information about the Freeradius-Users mailing list