User-Password required Authentication problem

Syed Anwarul Hasan syedanwarulhasan2007 at
Thu Aug 28 12:02:56 CEST 2008

Hi Alan,
Since I am using a Plain password in the LDAP database, hence I tried to do
LDAP Authentication with Auth-type set to LDAP.
Even I tried with only uncommenting ldap in Authorize and Authenticate
section of default file in sites-enabled.Still, I am having the Problem with
*no Authenticate method found for user error.
Please comment.
debug o/p:
++[ldap] returns ok
++[expiration] returns noop
++[logintime] returns noop
rlm_pap: WARNING! No "known good" password found for the user.
Authentication may fail because of this.
++[pap] returns noop
*auth: No authenticate method (Auth-Type) configuration found for the
request: Rejecting the user*
auth: Failed to validate the user.
  Found Post-Auth-Type Reject
+- entering group REJECT
        expand: %{User-Name} -> hasan
 attr_filter: Matched entry DEFAULT at line 11

On Wed, Aug 27, 2008 at 7:19 PM, Alan DeKok <aland at>wrote:

> Syed Anwarul Hasan wrote:
> > ... Also in the Sites-enabled dir under default file, I have
> > added in the Authorize section I added,
> > *update control {
> >   Auth-Type :=ldap
>   Why?  All of the documentation and configuration files say DO NOT DO
> ...
> > rlm_ldap: Attribute "User-Password" is required for authentication.
> > Cannot use " (null)".
>   You are sending the server a request that doesn't contain a
> User-Password attribute.
>  Don't set Auth-Type.
>  Alan DeKok.
> -
> List info/subscribe/unsubscribe? See
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list